3rd-Party Ubuntu ROM for Khadas VIM

Balbes150, why is there root password error(bug) in your Ubuntu image, it is correct at login screen, but it doesn’t accept the same pass in terminal.

I am pretty much new in Linux, so i don’t know if it has anything to do with the post above?

Did anyone else posted this issue or is it specific to khadas vim?

Describe in detail Your steps. Just for reference. Open a terminal in a graphical environment and give the command “sudo su”, enter the user password (pay attention , you need NOT to enter the root password, enter user password). The system will switch to the root user.

Another variant of transition to the root user. To run the command “su -” (su “space”, “minus”). And enter the root password (pay attention, this command uses the password for the user “root”).

I see that many of the themes frequently mentioned option of images with LXDE along with my name. I want to draw the attention of all - I never published any of the images for Amlogic (armv8 aarch64 S905\S905X\S912), with a graphical user interface LXDE. All the images that I produced are based either on the graphical environment XFCE, or in a graphical environment MATE or the command line options (without graphical environment). I think this is important, XFCE is significantly different from LXDE. This is a different GUI and they are configured differently. So anyone who uses my images, I recommend to look for information on the Internet about setting up the graphical environment XFCE.

1 Like

Hi, Balbes150:
Will you built Mate/Gnome desktop in the future?

Hi Gouwa.
I’ve collected several options for desktop environments, including MATE.

What do you mean: have collected several options? :slight_smile:

I had previously collected to test multiple images with different graphical shells (XFCE IceWM LXDE LXQT MATE etc). :wink: But these images were not in the public domain. By the way, the last images armbian make it easy to install any GUI. For example, I have on one of the TV box is running the latest image Armbian (20170121 catalog Test) which, together with XFCE installed MATE (via synaptic) and automatically (at system startup) start the shell MATE. Enough after installing MATE to add to the user directory file .xinitrc indicating what shell I want to run (in the file, add one line “exec mate-session”) :slight_smile:


Very glad to see you here balbes150. :slight_smile:
Thanks for the clarifications.
My apologies for the errors.

Same with me! :heart_eyes:

A very good user manual. :slight_smile:

Thank you.
You make it easy.:slight_smile:
I have edited the post’s incorrect DTB info and linked to your post explaining it.

One question for you guys, and not trying to put any preassure on the developers, but is there any sort of ETA for the availibility of working WiFi and BT drivers for the Khadas Linux builds?
And what is the blocking factor for not having them now? Do the drivers need to be backported to the kernel being used?

Balbels50’s ROM support WIFI already, but for SD card installation.

EMMC installation ROM with WIFI supported ROM will be released today.

Those are great news.
Although I’ve never been able to up the wlan0 interface even on Balbels50 SD distribution. Is there a particular release where it does work? And is there anything in particular to configure in order to be able to use it?

Which version ROM did you install?

Here I test both following versions, works fine here for both VIM and VIM Pro:

  • Armbian_5.24_Amlogic-s905x_Ubuntu_xenial_3.14.29_desktop_20161223.img
  • Armbian_5.24_Amlogic-s905x_Ubuntu_xenial_3.14.29_desktop_20170118.img

Without any manually setup.

If You’re interested, I’ve uploaded to your website image multivariada DE. Details can be seen here.


1 Like

Yes, I think Khadas users will happy to try more your ROMs.
And we will create a category for you if needed.

I went back to Android because of this, so i can’t check it again, and i don’t want to write eMMc until i’m sure everything will work.

When i tried to connect as root in terminal, i would get error about incorrect password, this was unix password that i have chosen.

When i pressed ctrl+alt+f2 to go to login screen, and immediately logging in as root user, password was accepted, everything was ok, but when i return to terminal, password was not correct.

I tried to change unix password, for myname@khadas and root@khadas, everything would be saved, but in terminal still nothing.

I am not a Linux expert, so sorry if this isn’t very understandable, i did explain to you the best i could.

I did try many passwords, default, nothing worked.

The only thing i managed to install pressing ctrl+alt+f2, logging as root, was Ubuntu software center.

Forgot to mention that i was trying to log in as root in terminal, entering ‘su’.

Try sudo -i from CLI or terminal.