What stuff doesn't work on VIM3?

With Linux it’s always more important what doesn’t work, than what works?

I am just being curious about what software doesn’t work or was dificult to install.

Are the Visual Studio Code for C++ and Eclipse for Java IDEs working?

I am most concerned about IDEs. But wouold like to know if OpenOffice suite works, as well, because I fancy using it as a desktop computer as well…

i know python works, PyCharm is available for VIM3
actually libreOffice works and is preinstalled in ubuntu


Does any office type app work?

I think you should flash Manjaro arm and test it all yourself,

We have libreoffice working and installed by default.
Most of the desktop apps are working. Some proprietory once need to add aarch64 to their apps like zoom doesn’t work, waiting for Anydesk, teamviewer to work on Aarch64 too.

I don’t think all of them are available for Aarch64 yet, but I think atom ide is there.


yes I believe atom IDE works
Note you will have to use wine to make it work

wine doesnt work on aarch 64 I believe

No I used it quite a bit ago, it works

Wine is for X86… You can’t run it natively in Arm64… you need to setup X86 emulation and then run wine… There is going to be a huge performance penalty…

I am talking about windows apps that run natively on ARM
i agree with x86 emulation I just tested some apps that do have support for ARM

the above link runs app on emulation not natively

oops, didn’t see that :grimacing:

Ubuntu Linux 18.04.5, kernel 4.9.224 does install but DOES NOT START[WORK] (Segmentation fault error upon application start):

  • okular (Qt universal doc-viewer)
  • goldendict (feature-rich dictionary lookup program)
  • vlc (multimedia player and streamer - doesn’t work GUI only ‘cvlc’ command available & does play files)
  • smplayer (Complete front-end for MPlayer and mpv)
  • djview4 (Viewer for the DjVu image format)
  • tea (graphical text editor with syntax highlighting)
  • stellarium (real-time photo-realistic sky generator)
  • kompare (Qt file difference viewer)
    …maybe some else popular tools I haven’t tried to use.

Dmesg shows some stuff from ‘fb’ module about osd but there are no errors concerned this module.

1 Like

fb module ? you mean like mali fbdev the basic graphics driver ?

[   31.594959] fb: OSD2 as afbcd mode,afbc_type=2
[   31.596121] meson-fb meson-fb: create ion_client ffffffc07f040b40, handle=ffffffc099c70680
[   31.599000] meson-fb meson-fb: ion memory(2): created fb at 0x00000000ea500000, size 1 MiB
[   31.607401] fb:  2, phy: 0x00000000ea500000, vir:0xffffff8012472000, size=1024K
[   31.607404] fb: Frame buffer memory assigned at
[   31.607406] fb:  2, phy: 0x00000000ea500000, vir:0xffffff8012472000, size=1024K
[   31.607409] fb:  2, phy: 0x00000000ea500000, vir:0xffffff8012472000, size=1024K
[   31.607412] fb: logo_index=0,fb_index=2
[   31.607414] fb: ---------------clear fb2 memory ffffff8012472000
[   31.607587] fb: osd[2] canvas.idx =0x41
[   31.607589] fb: osd[2] canvas.addr=0xea500000
[   31.607590] fb: osd[2] canvas.width=128
[   31.607592] fb: osd[2] canvas.height=32
[   31.607593] fb: osd[2] frame.width=32
[   31.607595] fb: osd[2] frame.height=32
[   31.607596] fb: osd[2] out_addr_id =0x3
[   31.611709] fb: vpu clkc clock is 199 MHZ
[   31.611723] fb: malloc_osd_memory, cma:ffffff800acf00d8
[   31.611727] fb: malloc_osd_memory, 1232, base:0x000000007f800000, size:8388608
[   31.611729] fb: use ion buffer for fb memory, fb_index=3
[   31.611730] fb: OSD3 as afbcd mode,afbc_type=2
[   31.614960] meson-fb meson-fb: create ion_client ffffffc07f040b40, handle=ffffffc099c1a440
[   31.617862] meson-fb meson-fb: ion memory(3): created fb at 0x00000000ea600000, size 8 MiB
[   31.626223] fb:  3, phy: 0x00000000ea600000, vir:0xffffff8012573000, size=8192K
[   31.626226] fb: Frame buffer memory assigned at
[   31.626229] fb:  3, phy: 0x00000000ea600000, vir:0xffffff8012573000, size=8192K
[   31.626231] fb:  3, phy: 0x00000000ea600000, vir:0xffffff8012573000, size=8192K
[   31.626233] fb: logo_index=0,fb_index=3
[   31.626235] fb: ---------------clear fb3 memory ffffff8012573000
[   31.627682] fb: osd[3] canvas.idx =0x42
[   31.627687] fb: osd[3] canvas.addr=0xea600000
[   31.627689] fb: osd[3] canvas.width=128
[   31.627690] fb: osd[3] canvas.height=32
[   31.627692] fb: osd[3] frame.width=32
[   31.627694] fb: osd[3] frame.height=32
[   31.627695] fb: osd[3] out_addr_id =0x4
[   66.586268] fb: mem_free_work, free memory: addr:800000

– I think that was about these kernel-messages.

Additionally tried start by debugger and have got these:

Starting program: /usr/bin/okular
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/aarch64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fb0b32130 (LWP 3878)]
[New Thread 0x7fabfff130 (LWP 3880)]
[New Thread 0x7fab7fe130 (LWP 3881)]
[New Thread 0x7faaffd130 (LWP 3882)]
[New Thread 0x7faa7fc130 (LWP 3883)]
[New Thread 0x7fa9ffb130 (LWP 3884)]
[New Thread 0x7fa97fa130 (LWP 3885)]
[New Thread 0x7fa8ff9130 (LWP 3886)]
[New Thread 0x7fa87f8130 (LWP 3887)]
[New Thread 0x7fa7ff7130 (LWP 3888)]
[New Thread 0x7fa6e46130 (LWP 3889)]

Thread 1 "okular" received signal SIGSEGV, Segmentation fault.
0x0000007fb3ea82d8 in specific_new_surface () from /usr/lib/aarch64-linux-gnu/libGLESv2.so.2

Other starts (djview4, stellarium, vlc) produce the same sort of last string

– looks like some fault in Mali OpenGL ES lib/driver support?
What would look else to get more details?

GLX version: 1.4
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 10.0.0, 128 bits) (0xffffffff)
    Version: 20.0.8
    Accelerated: no
    Video memory: 3707MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 10.0.0, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.0.8
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

Will try How can I use qt with npu
Thank You Very Much!

If you still stuck it, you can try :

It works for me!

Is Qbittorrent properly working on vim3, ubuntu And manjaro both?

Yes works fine on Manjaro Arm.

1 Like

As you are a manjaro Dev, i think is relevant to ask you this… KDE plasma version latest, when it is released for x86, similarly at same time it is released for arm sbc or there is delay?

A more better question will be, what are the core differences between arm manjaro and x86 manjaro in terms of software availability?