Weird touchscreen problems with the Mind

I’m using a touchscreen-based monitor and the Mind seems to be having some problems registering “hand-based” touch from the monitor. It can read the stylus perfectly but it can’t read hand gestures at all.

I’ve updated all my drivers time and time again, updated the firmware, did an In-place upgrade, and reuploaded Windows 11. It simply won’t register touch from the screen while registering it perfectly from the stylus. Not even in the control panel > Tablet Settings > Configurations or Setup. i also updated my touch settings in Wisp. Quite frankly it’s driving me crazy.

If anyone has any ideas, I would really appreciate it.

Hello @Kernda03

Can you provide us which souch screen you used?

By the way, does it work on other PC?

(post deleted by author)

Hello @Kernda03

We don’t have the same touch screen on our side now, but we tested other touch screen and it works on our side, have you ever checked other touch screen?

I just used a different one. Unfortunately I got the exact same response. Pen is working perfectly, hand gestures aren’t working at all.

Hello @Kernda03

Do you use the same model or others?

No different monitors

So I tried Reinstalling Windows 11 again and I ran into brand new problems :frowning:

Is it possible that my unit is damaged and needs to be repaired?

Greetings, we have already responded to your inquiries via email.
If there are any updates, you can reply to the email or respond here.
We will continue to Track your issue.