VIMs && Edge Ubuntu Firmware V190830 Rom Release



Config to be used with this? Fenix one or a diff one?


Thanks for the quick response.

I will start to compile it tonight.

1 Like

改睡觉啦~ :rofl: :rofl::rofl:

Tried to install latest desktop version ( VIM1_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20190830 ) but i get exactly the same error message that showed up when I tried to install the former version time ago:

At a 99% of the process, when it’s about verifying the rootfs partition it ends up with the known error message. :S

Am I the only one experiencing this problem ?

I think you’re using the old burning tool.

Please try with the new one recommended by khadas team

after the installation some tailoring / modifications are usually needed. After that, what is the easy way to clone the modified and tested installation?

Is there a way to save the VIM1 eMMC content to SD-card so it can be used for cloning similar VIM1 installations?

Or is there a way to save the eMMC image so that it can be used with burning tool for the cloning purpose?

is there a way

Hello, search these forums for the term DDBR. I would think you can still use Armbian running from SD card to back up the eMMC.

I just flashed Ubuntu XFCE 4.9 on VIM1 and everything was fine.

Now I have a full working Linux distro with Kodi.
Also tested booting other linux distro and it boots with its own kernel from the USB.


tks @Frank but how to make OTA update work ? and how do we know that there is an available update ?

Yep, the most recent burning tool did the job.
Thanks for the hint !

Did not have enough time over the weekend to really try out this newly installed Ubuntu version. What I’ve noticed so far is BT sound works fine. On the other hand, 720p videos opened with the preinstalled Chromium Browser seem rather laggy (guess it does not make much sense to try out FHD within a Web Browser, then).

Haven’t tried Kodi yet.
What is the max. resolution supported by Kodi in this Ubuntu version ? FHD ?



It would be disappointing if HD video is not fluid in chromium or at least in one other browser !

@ravelo sudo apt update && sudo apt upgrade

1 Like

i’ve juste finished building in docker & w/ the lastest fenix, an image called VIM1_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20190903.img (incl. uboot 2015)

once 7zipped, is it supposed to be the same as we can see in post#1, @Frank ?

@ravelo It’s the same one.

Nice to see the new VIM3 Ubuntu image picks up my NVMe drive(Patriot Scorch 128GB) without effort. Good job Team Khadas.


Ok, flashed my EMMC with my own home made image : it boot ok , says 'built with fenix 0.7 and kernel is 4.9.190" !

this is not new, previous builds were already able to update this way; so I tried apt dist-upgrade and I’ve seen that kernel 4.9 header did update & ubott was regenerated !

khadas@Khadas:~$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libnss-myhostname libnss-systemd libpam-systemd libsystemd0 libudev1 linux-headers-amlogic-4.9 systemd
  systemd-sysv udev
9 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 14.8 MB of archives.
After this operation, 305 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 bionic-security/main arm64 libnss-systemd arm64 237-3ubuntu10.28 [90.5 kB]
Get:2 bionic-security/main arm64 libsystemd0 arm64 237-3ubuntu10.28 [171 kB]
Get:3 bionic-security/main arm64 libnss-myhostname arm64 237-3ubuntu10.28 [30.3 kB]
Get:4 bionic-security/main arm64 libpam-systemd arm64 237-3ubuntu10.28 [92.5 kB]
Get:5 bionic-security/main arm64 systemd arm64 237-3ubuntu10.28 [2,553 kB]
Get:6 bionic-security/main arm64 udev arm64 237-3ubuntu10.28 [1,050 kB]                  
Get:7 bionic-security/main arm64 libudev1 arm64 237-3ubuntu10.28 [45.3 kB]               
Get:8 bionic-security/main arm64 systemd-sysv arm64 237-3ubuntu10.28 [11.8 kB]           
Get:9 bionic/main arm64 linux-headers-amlogic-4.9 arm64 0.7 [10.8 MB]           
Fetched 14.8 MB in 21s (694 kB/s)                                                                                
(Reading database ... 55597 files and directories currently installed.)
Preparing to unpack .../libnss-systemd_237-3ubuntu10.28_arm64.deb ...
Unpacking libnss-systemd:arm64 (237-3ubuntu10.28) over (237-3ubuntu10.26) ...
Preparing to unpack .../libsystemd0_237-3ubuntu10.28_arm64.deb ...
Unpacking libsystemd0:arm64 (237-3ubuntu10.28) over (237-3ubuntu10.26) ...
Setting up libsystemd0:arm64 (237-3ubuntu10.28) ...
(Reading database ... 55597 files and directories currently installed.)
Preparing to unpack .../libnss-myhostname_237-3ubuntu10.28_arm64.deb ...
Unpacking libnss-myhostname:arm64 (237-3ubuntu10.28) over (237-3ubuntu10.26) ...
Preparing to unpack .../libpam-systemd_237-3ubuntu10.28_arm64.deb ...
Unpacking libpam-systemd:arm64 (237-3ubuntu10.28) over (237-3ubuntu10.26) ...
Preparing to unpack .../systemd_237-3ubuntu10.28_arm64.deb ...
Unpacking systemd (237-3ubuntu10.28) over (237-3ubuntu10.26) ...
Preparing to unpack .../udev_237-3ubuntu10.28_arm64.deb ...
Unpacking udev (237-3ubuntu10.28) over (237-3ubuntu10.26) ...
Preparing to unpack .../libudev1_237-3ubuntu10.28_arm64.deb ...
Unpacking libudev1:arm64 (237-3ubuntu10.28) over (237-3ubuntu10.26) ...
Setting up libudev1:arm64 (237-3ubuntu10.28) ...
Setting up systemd (237-3ubuntu10.28) ...
(Reading database ... 55597 files and directories currently installed.)
Preparing to unpack .../systemd-sysv_237-3ubuntu10.28_arm64.deb ...
Unpacking systemd-sysv (237-3ubuntu10.28) over (237-3ubuntu10.26) ...
Preparing to unpack .../linux-headers-amlogic-4.9_0.7_arm64.deb ...
Unpacking linux-headers-amlogic-4.9 (0.7) over (0.7) ...
Setting up libnss-systemd:arm64 (237-3ubuntu10.28) ...
Setting up libnss-myhostname:arm64 (237-3ubuntu10.28) ...
Setting up systemd-sysv (237-3ubuntu10.28) ...
Setting up udev (237-3ubuntu10.28) ...
update-initramfs: deferring update (trigger activated)
Setting up linux-headers-amlogic-4.9 (0.7) ...
Compiling headers - please wait ...
Setting up libpam-systemd:arm64 (237-3ubuntu10.28) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for dbus (1.12.2-1ubuntu1.1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for initramfs-tools (0.130ubuntu3.8) ...
update-initramfs: Generating /boot/initrd.img-4.9.190
update-initramfs: Converting to u-boot format

one step flashing example, just in case someone would need to know:
7z e -so xxx.7z | sudo dd of=/dev/sdY bs=8M status=progress
replade xxx and Y by whatever id is appropriate in your case

I’ve started this one VIM1_Ubuntu-xfce-bionic_Linux-5.3-rc4_arm64_SD-USB_V20190830
but the GUI does never start on the TV connected over HDMI ! console displays boot logs then presents a shell session, and TV display shows some start logs then freezes after a few seconds

1 Like