VIMs Ubuntu with Linux-4.9 New Release ROM V190604

Here we release some New Ubuntu ROM with Linux-4.9 for VIMs.


ROM Info

  • VIM1_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20190604
  • VIM1_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20190604
  • VIM2_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20190604
  • VIM2_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20190604
  • VIMs_Ubuntu-server-bionic_Linux-4.9_arm64_SD-USB_V20190604
  • VIMs_Ubuntu-xfce-bionic_Linux-4.9_arm64_SD-USB_V20190604

Change logs

  • update kernel to 4.9.179
  • add Kodi (19.0-ALPHA1) support (Just for VIM1)
  • fixup bluetooth issue
  • fixup RTC issue
  • update ubuntu rootfs

Known issues:

  • Kodi drags progress bar will cause the system to crash

SD card new release is universal on VIMs.There is how to use it.


Hi, I tried flashing the firmware VIM1_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20190604 desktop but the image has a problem and before finishing the flashing fails. On the other hand, the server image has no problems.

Same here, the flashing of firmware “VIM1_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20190604 (desktop version)” ends up in an error message at 99% of the process when it comes to verifying partitions.

Hello @juanesf @dormilon

Have you flash the image on Ubuntu or windows? What’s the version of the flash tool? If you flash on windows you should use V2.1.7.0.
If you flash on Ubuntu, you should update the utils repo.

When it failed, if you reset the board manually by pressing the RESET key, does it work well?


1 Like

Hello numbqq,

in my case Windows 7 + USB Burning Tool 2.1.7 were used.

I will give the RESET key a try at the next attempt…


When it failed, if you reset the board manually by pressing the RESET key, does it work well?

Zero effect. The same error shows up at the same point of the flashing process. Just citing:
“[0x30405004]UBOOT/Partition rootfs/Verify patition/Error result”

(Btw: Guess this detail has no importance, but just in case…My Khadas board is a VIM1 Pro.)

Does Wi-Fi work on VIM2 Pro/Max?

This is not mainline kernel, so, Wi-Fi works.

Hi, i have received a new Khadas VIM 1 Basic and it works fine, however i just flashed this image and the red light wont stop flashing, i dont know what to do.

If i boot from the microSD, the red light is ok, and LibreELEC works mostly fine(I have issues with Plex and 4K HDR content, but it seems a LE temporary situation, not Khadas VIM 1 Basic’s related).

I have flashed the server version 4.9 into the EMMC, i think it is this one:

  • VIM1_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20190604

Can you help me to make it stop ? That red flashing light is a little bit annoying LOL

You can edit /etc/rc.local to disable it.

# sudo vim /etc/rc.local

Comment the line: echo heartbeat > /sys/class/leds/led-sys/trigger

And reboot your board.