VIM4 stuck on boot

Which version of system do you use? Khadas official images, self built images, or others?


Please describe your issue below:

After flashing this image, the VIM4 doesn’t boot. It shows the Khadas logo, flashes to black briefly and then show the Khadas logo again, where it stays forever. No spinning wheel with the Ubuntu logo next to it as usual from the VIM3 images I’ve been flashing.

I tried several times on three different VIM4 devices, all with the same result.

When flashing vim4-ubuntu-22.04-server-linux-5.4-fenix-1.2-221018.img.xz, everything works as expected.

BTW: After running do-fenix-full-upgrade and booting the device, I have the same issue. The same is true after apt dist-upgrade. I guess that’s because I forgot to comment out /etc/apt/sources.list.d/fenix.list.

Update: I figured the device isn’t really stuck at boot - it’s just the Khadas logo never disappears, so I can’t login to the console. The same is true after installing X. Other than the display, the device appears to behave normal: I can ssh into it, install packages, start services etc.

Correct, you can also get into it via debug port.

Make sure your monitor is connected and powered up when it boots. I have the same issue and it randomly occurs but we don’t use the HDMI on the board so its a not a priority at this time. Did build an image in fenix a couple days ago and the boot screen does not have the color issue so might try a fresh image.

Thanks for having a look. I know the device needs to be connected to the screen at bootup - the same is true for the VIM3. The issue with the VIM 4 is that the Khadas logo sticks on the screen. Unfortunately, the same is true for the Edge2 with all ubuntu images - see my post in other forum. How comes I have seen people using it with Ubuntu on YouTube? Where do they get the image from?

For us, this issue is a hard showstopper: We need HDMI output for a media player app. We are currently using the VIM3 and we are looking for a more powerful successor. Therefore, I have ordered several VIM4 and Edge2 devices and now it turns out they are completely useless because of this issue.

oowow has several images or you can build if in fenix.
Only 22.04 will work.
We did test it as desktop configuration for while and it does work. Don’t recall if the board had the same issue as it does running headless. At the time it had some issues due to possibly the wayland transition, not any fault of Khadas. Stuff for ARM does not get the same attention as AMD64.

When they get back from the holiday you will get some official help. Team Khadas is good about taking care of things if it is something that can be fixed by them.

1 Like


it seems like i have the same or similiar issue.

I have a VIM4 with a TS050 display connected. I had Ubuntu Server running on it several month now, but started to playing around with it yesterday.

I flashed android 11 via OOWOW, but upon restart, it never came back.
When it boots, you can see Khadas Logo flashing briefly, then turn black and repeat again endlessly.

If trying to access OOWOW, i simply cannot because it seems whenever i try to boot into OOWO or an external boot source, there is also a bootloop but now with logo flashing briefly, fan spinning up briefly and then restart and repeat endlessly.

Is there any possible way to at least get SOME access to the VIM4 again?

I’m happy to supply any information necessary!

Please make sure you use the 24W PD ataptor.

Please use the HDMI screen to access the OOWOW. Or you can use the web to access OOWOW.

Thank you for replying!

I just bought the original Khadas 24 Watt PSU, but behavior is still the same.

I disconnected the Touchscreen (where I had at least the khadas logo flickering) and connected only to a Monitor via HDMI.

This doesn’t help, because there is no continuous signal through HDMI, ergo Monitor stays off.

I did not try access OOWOW via web (yet) , but I doubt it to be successful because to me it seems like the device is constantly power cycling

Waht’s the resolution of your screen ?

Could you try to boot oowow from the SD card?You can follow the steps below:

  • Download image and write to SD card, you can check this docs
  • Insert the SD card to VIM4 and power on

By the way, is there a chance for you to get some logs from the uart debug console?