VIM4 stuck on boot/boot loop

Which version of system do you use? Khadas official images, self built images, or others?

Official Khadas images:

Please describe your issue below:

I used OOWOW to install each of the above images to emmc, to see if any worked. Each fresh install (after the required reboot) results in the system displaying the Khadas logo for 5s, going blank, then repeating, forever. This is similar to these other posts:

I have tried using different HDMI cables, different monitors, using a 30W USB-C adapter, and having no other devices plugged in, as has been suggested in these other posts, but nothing seems to solve this issue.

HOWEVER! Using OOWOW to install to emmc the following official image:


results in a successful system boot, and everything works completely fine.

Is there anything else I should attempt, or be aware of? I am fine with using the older build, but would prefer to be able to use the most recent version.


Do you use or official PD adaptor?

I’m not using the Khadas adapter, as they don’t come in AU plugs. I’m using a 30W PD USB-C adapter that I also use for my VIM3 (22.04-gnome-linux-6.0), which works fine. My VIM4 is currently running the 20.04-server-develop image, and is running well. I only encounter the boot loop problems with the other official images, installed using OOWOW.

For boot loop problems are cased by power supply mostly.

Do you have a chance to setup the serial debug console and capture the full bootlog?

I tried to setup the serial debug console, but cannot even connect to the VIM4 (no device found). I will try to do the same for the other image install, see if I did something wrong. Just to confirm, do I just connect the TX, RX and GND USB pins to the VIM4 (pins 17, 18, 19), or do I also connect the VCC (pin 20)?

Just the three - I found that connecting VCC made the board unresponsive even from the serial console. The USB-to-TTL cable I used was kinda cranky too - even with the correct drivers, I got gibberish in the terminal window on my Mac, while it worked perfectly plugged into one of my Linux boxes.

Ok. So debugging console still doesn’t work. However, on a whim, I thought I’d try to SSH into the VIM4 from my VIM3, and it seems that it’s working, but for some reason, not outputting the HDMI properly, just showing the Khadas boot logo. Fortunately, I’m intending to run the VIM4 as a headless server anyway, but just wanted to know if this is a known issue, and if there any ideas how to regain the HDMI output (in case I lose SSH access, somehow).

What issues you have ? Do you setup under Windows ? or Linux ? or Mac? Could you please share us the hardware connections?

Tried using Windows, with Putty. I have a USB-to-TTL adapter, connected the USB to my PC, and the 3 connectors to the pins on the VIM4, as was shown here: VIM4 Setup Serial Debug Console [Khadas Docs]
But Windows didn’t recognise any serial device (even in Device Manager).

Maybe you need to install the driver of USB to TTL Serial Adaptor, you can try to get it from the vendor.

I just thought of something. I have access to the bootlog through dmesg. Would that help? And is there anything in particular I should be looking for (e.g. dmesg | grep xxxx)?

But you said the system stuck on boot, how you get the dmesg?

Oh, I said in a previous message that it seems the VIM4 is booting up, but is simply not outputting the HDMI as you would expect (instead just showing the Khadas logo). I found this out by trying to SSH into the VIM4 using my VIM3, which worked. So I can access the VIM4 (but only through the VIM3), and therefore, dmesg.

I have had two VIM4’s go unstable - (boot-looping) I recovered by using the OOWOW’s emmc full erase and then selected the factory reset option (I am away from the units, so cant tell the exact wording for the reset)

it took about 30 minutes to format… then re-installed and it worked fine since.

Please attache the HDMI cable and then reboot. You need to make sure your HDMI cable is attached before you power on the device.

Surely not with one of your server images ?

Please attache the HDMI cable and then reboot. You need to make sure your HDMI cable is attached before you power on the device.

I did that. Still having the boot logo issue. No idea what’s the cause. Is there anything I should look out for in the dmesg log?

We need more information from the uart debug console, so please try to make it work.

Sorry, I’ve tried everything I could think of, but still cannot get the uart console to work, and am just at a complete loss. Only thing I can do I suppose is to wait to see if this issue gets fixed (don’t seem to be the only one). The only upside is that at least I can use the VIM4 as it is, since I don’t need the video output. Thanks for the assistance, all the same.

please try latest oowow images

1 Like