VIM3 Ubuntu Focal eMMC apt update bricks

Installed from

When I run apt update and apt upgrade, the box is bricked. I am assuming that this is do to a new Kernel install and uboot needs to be updated to point to the new kernel. This results in having to flashback to original. Anyone know a good way to block kernels without having to manually select upgrades around brickers?

I am preferably waiting for a Manjaro eMMC image, but I understand this is a process. Any visibility into how uboot points to kernels would be appreciated.

I assume that uboot must be updated and maintained on the ubuntu side. There has to be a better process to keep pace with kernel updates to match uboots. I don’t know if that would look like a uboot firmware download folder? Maybe even a github that is maintained that distro managers can pull from and include in their pushes? I don’t know, someone may be better knowledgeable than I.

1 Like

Hi @redairforce and welcome to the forum,

I am sure you have taken a short tour of the forum by now, Please note that the firmware you are using has a few bugs in it, please procced to update the firmware to a later build,

Fresh Ubuntu/Debian images can be made using Fenix

If you do not have access to a Linux computer, I can provide you with the latest build of the preferred image… :slightly_smiling_face:

Good day!

@Frank Please help to check this issue.

@numbqq I believe I was the one who pointed you to that issue, you had solved it in a later with a few commits to the fenix-repo…

If i can recall the incident, the problems was related to something in the rootfs partition

Can you point me which commit ?

I am not exactly sure, but the problem is related to the image made with timestamp :20200530

I however do recall you were the one who helped solve the problem…

please notice that this image alone had such problem, you can ask @frank if he remembers

OK. Thanks, we will check this issue.

please note the latest discussion of the problem here:

Thank you very much!

I just reflashed focal fossa to emmc today and ran apt upgrade. Everything working okay. I am guessing something was added to the VIM repo since my original issue. The best I can tell the repo isn’t updated real time with Ubuntu updates. I may have just been attempting in the window of lag.

1 Like

Is this with the same 20200530 image ?


Ok, see how well it goes, and report back to us if there are any problems…

By the way, can you check if you can use TF cards without the HDMI connected on that version of firmware ?, We are trying to get debugging info from users of that image…

Very annoying, but I think someone else already reported that UFW doesn’t work.

if there is already such information, including from you

yes, it seems to be a serious issue, do not worry however, The khadas team has already understood the problem, they will fix and solve it for us… :slight_smile:

Yes I understand that part, I am just trying to make sure everyone is on the same page here…

yes, help us all please solve this problem :neutral_face::wink:

I am on it buddy, If there anything I can do for the community, I will definitely try to do it…

You position yourself as an all-knowing, number one on the forum, with you the demand is higher

There is nothing like that, I am just trying to dedicate my free time to help others, I still have a lot to learn,
I too am just a simple person like any other forum member, do not mistake me for my doings…