VIM3 network no longer active

My VIM3 can no longer connect to any network. I have flashed the EMMC back to factory Ubuntu 4.9, tried latest Ubuntu SSD build, and even Manjaro.

Under all OS, the network shows as available. I can even netplan DCHP and get an auto assigned address and netplan a static IP.

The real problem is the failure to initiate connection. I have connected to several routers and switches and do not get active connection (lights will not turn yellow, green).

It is just strange to me that the OS can see the network card and can be controlled, but the network will not initiate with any switch or router device.

Hello, I assume you have tried different cables between VIM3 and router/switch.
You may wish to clear eMMC and flash it again.
I have not experienced this issue, so unfortunately my advice is limited.

Hi, are you talking about WiFi or LAN?

I have indeed cleared the eMMC module and downloaded a fresh image from the Khadas inventory and flashed eMMC. I am actually able to get wifi to connect, but eth0 is where the issue lay.

Have you changed the LAN cable?

If you have already tried different LAN cables, next I would visually inspect the LAN port. Look closely to see if the contacts inside are straight and uniform as compared to their neighbors.
I had some cheap cables once, not all contacts had been fully seated in the cable’s headshell. That resulted in deforming the LAN port’s contacts.
Next I would take high-res photos of the LAN port to PCB for analysis by Khadas Team members.

Sorry about the close up of my dirty hands. It was hard to get light in there. I only use high end CAT6 cables and have swapped through new ones in their package from my datacenter. I don’t see any visible damage to the connectors.

Try to get a photo that shows the LAN port’s solder joints and the corresponding IC(Pulse), as shown in this picture…

@redairforce sorry to for asking, if you have already said this, are you sure,
ifup eth0
doesn’t do anything ?

Quick update. I finally got it to work. I was able to flash eMMC and it worked, then I flashed SSD and it worked. The only trouble came when I hooked up my USB hard drive. All of the sudden the network was knocked offline again and would no longer connect. I removed the USB drive and the network still won’t connect. Worst of all, now the USB ports don’t work at all. I flashed eMMC again and it won’t connect either network or USB. With no way of entering input, looks like I’ve got a paperweight.

@redairforce try reflashing the eMMC again,
P.S did you use something like VIM3-Ubuntu-4.9-EMMC-200530.img ?

Okay, I’ve got it up and running using the latest Manjaro SSD image with the latest EMMC Ubuntu image on the EMMC. It would appear that you need a stable EMMC Unbuntu and cannot touch it. In another thread, someone said that once I got booted on an EMMC that I could reformat /dev/mmcblk2 as empty ext4 and mount it.

This may not be recommended. I couldn’t get it running properly until I did a full wipe of EMMC and flash of a stable Ubuntu 4.9. Once running, I got up on an SSD and then formatted and mounted the EMMC and bam - lost network again. So I did it all over again. This time I will just leave the EMMC alone.

@redairforce what version of firmware are you flashing ?


just as suspected…
@redairforce that image has that problem, its known and verified, hence I asked before.

I’ll whip up a new image for you to try. that should fix all your problems :slight_smile:

1 Like

@redairforce, @friendmy,
here is latest image built, you can get it from here.
Its is


Firstly, this is not your image, but publicly available for everyone!(renamed Krescue backup).
And secondly, the person clearly writes that his LAN does not work on any firmware, therefore, the problem is not software, but hardware!

I initially thought h/w too, but their post seems to work against that. Though it does not entirely rule it out.

VIM3_Ubuntu-gnome-focal_Linux-4.9_arm64_EMMC_V0.9-20200530 operates normally.
So, I don’t think it’s a H/W issue, it’s the latest source issue.

Hello! the person writes that the problem with this image :man_shrugging:t3:

You confirm that everything works well for you, then the problem is definitely hardware.