VIM3 Android Pie V201112: Fan not working!


i found with the new VIM3 Android Pie V201112 ROM Release
my fan is not working anymore. It is the genuine khadas fan and has worked with the old version of android. This install is a fresh install (I did it two times now without any bettering)

Any hints?

What’s the hardware version of your VIM3?
In addition, you are sure to burn the last firmware, can your fan work normally?

Hi, how can I find the HW version?
I have burned everything that was in the software package.

Does your fan only can’t work on the new firmware?


I just flashed the prior Android Version and its not working anymore. I checked the connector, all seems fine.

HW-Version is V12

Is there anything else I can do to try to repair it?
I also found out the usb port next to the ethernet port has stopped working. I haven’t looked into that yet, just in case it might hint to something?

Ok, tried out all of the old roms I had and it still is not working. I am confident i was working before the update, as you might know the fan is kind of noisy…

It seems the new update has broken the fan…
Anything I could do?

@Terry I really need support on this. My device will run hot if the fan is not running… is there some possibility to solder the pwm input of the fan to some gpio for controlling it via android or anything else?

@Terry: It is also not working with them most current Ubuntu…

Have you activated the fan in settings, because it is deactivated by default I think

Yes I did activate it. In Android via Menu, in Ubuntu via commandline
I also could not measure PWM on the pwm line of the fan.

I think that the Fan is broke you have. please check the seat and line of the Fan.

1 Like

You are absolutely right!
I took another 5V fan I had lying around and it worked well.

Thats the first time I had a fan fail on me…
And by chance it happend to be just after the update. Thanks a lot for your help, I will order a new fan.

1 Like