Vim3 Android Bluetooth HSP/HFP failed

remote, ok I have a remote with mic on my Nvidia Shield
I will test with that when I can.

I have not been able to get any blue tooth microphone input at all.
I now feel I am doing something wrong, can I ask for a step by step way to test this.
devices I have to test with:
Nvidia Shield remote.
Bluetooth 4.1 Helmet Headset intercom,SCS ETC S-9 Motorcycle Communication System.
FreedConn COLO Motorcycle Bluetooth Helmet Headset Intercom
all these devices work on cell ph and tablets with the google assistant in the way I want it to work on the Vim3

Is there an app I should use to test this?
I tried using Lesser AudioSwitch to redirect what microphone input was in use.
It seems like its listening to a phantom nonexistent onboard mic and not the BT mic on whatever device I am useing.

My end goal is to have google assistant functional for a hands free GPS experience.
Thank you.

1 Like

Hi, in fact, there are two options, either wait or try to do it yourself, try downloading Google from the Market, someone wrote that it works on stock firmware, I personally have not tested

Hi, I am downloading the google assistant from the play store / market. I am also testing with the search function (mic) on the play store. Neither work.

As far as trying to work it out myself, I just dont have the time, full time working for a living and family life leaves only so much time for hobbies. I do want to learn app development for android, but that is a year or two down the line for me. The time it would take me to learn to compile my own image with the changes/repairs I need… unthinkable IMO.

1 Like

I agree with you buddy, I’m just talking about the things that we face :roll_eyes:

1 Like

So I take it there should be no need for Gapps or any other add on with the stock image or the superceleron images?

I am about to give up and wait for the next major revision now :frowning:

If I may ask, please ensure BT audio microphone input is on the radar as the android 11 image is prepared.


1 Like

As I said above, please wait for it. Thanks!

1 Like

Ok, thanx. Enough I guess, wont bug you guys further.

She is parked in a box till the new version comes out.
Need to get an RTC battery anyhow and that’s gonna take a month or four…


Sorry to bring this back, but the new version has come out and after testing I have seen no change in this problem.

Is there a better place to post this issue and monitor progress on bug reports like this one?


Hi buddy, I think Terry made a surprise for you, please check!:slightly_smiling_face:

All excited to try it and cant get it, its not on the firmware page yet :frowning:

edit: found it on another page:

1 Like

I found links for you to the latest firmware depending on your vim, good luck!

This vim3

This vim3L


Sigh, still no joy on my end.
I cannot get any Bluetooth microphone input :frowning:

I make sure that the new firmware can support the Bluetooth microphone input.
Why is your Bluetooth microphone not working? How did you test it?

I load the image, boot up the board then:

  1. connect wifi
  2. log into google account to access play store.
  3. Pair blue tooth mic (tried two helmet systems for motorcycles and one bluetooth remote that has a mic in it)
  4. test by using mic button on google play search.

You should use the Bluetooth headset, and it don’ t support the Bluetooth remote.

Ok, I will try again with my BT helmet headset.
This is a standard BT headset, nothing special.

I am loading it up right now.

The goal is to use android assistant as a hands free system when on my motorcycle.

I forgot I had to install the google assistant and voice search apps from the play store.
another app I installed was google maps.

These are as I see it the fundamental requirements for a hands free Android system.

I was not able to make this work in my tests with my bluetooth headset just now.

Terry, I really need a hands free Android system via BT

Can you help me with this in some way please.

what am I missing, I am at a wall and have been here for many months :frowning:

At this point I am willing to mail you a BT head set for testing…

You have tried to test the BT headset with the QQ call. It work well.