VIM3 and M.2 SSD - which ones work and which ones don't

Hi - I was just trying out the VIM3 with the m2x extension board and of course couldn’t get my little PCIe SSD (mydigitalssd 120GB) to work. I went back and checked this forum and noticed folk talking about certain ones not working and things like a patriot brand and of course a Samsung evo 970 working just fine. From that small sample, they seemed to both be PCIe 3.0 devices where my SSD was is a PCIe 3.1. Is it just the PCIe interface spec or is there a little more to what makes a compatible SSD for the VIM3?


@YeagerTheCat Did you set your port to PCIE ?

Excellent point - yes sir, it is set, command line instructions followed. I will try to reseat the device this morning just to make sure.

I may try removing the m2x board and just plugging it straight in.

This is the device in question:

Hello, What OS is on your VIM3?

@YeagerTheCat same issue here - i have tried all the khadas Linux OS’s now and can’t get any of them to see the drive, also the 2nd nic is not working though provides power just fine through POE.
Could you test to see if you see the second nic in your system (ip addr or ifconfig), that would be useful to know if its working for you :slight_smile:

@YeagerTheCat Maybe you can check the node /dev/nvme0 ?

Hi! Ubuntu 5 RC - the standard VIM3 image.

I will check tomorrow and let you know. Today I had some distractions :slight_smile:

And good sir, I surely will. The VIM overall is a fun little board. You guys packed a lot of stuff into a small space.

@YeagerTheCat OK , tell me the result after you check it

I have removed PCIe support for VIM3 with linux 5.x due to a bug.

So you can’t use it on 5.x now. We will add support for next release.

If you want to use the M.2 SSD please use the 4.9 kernel.


Sorry for the delay in getting back to this.

Ah! Ok, I will try again with the 4.9 kernel and see what I see and report back. Thanks again!


Just tried mine on 4.9 but still no go unfortunately - no NVMe seen

Well, have just thrown the m2x board back on the VIM3 and stuck my $20 SSD on it and low and behold, I see /dev/nvme0 on it. I have partitioned it and formatted it and later I will try and do something with it. So I can confirm it functioning with a mydigitalSSD 120GB shortened m.2 drive.

I did some some crazy video artifacts when I first started using it but this went away and I don’t know what it was and I don’t know why. Still it is progress!

I did try the POE ethernet port - I don’t have anything POE capable to try the power side out but I do note that I didn’t see anything out of the adapter. I moved my ethernet back to normal port and of course all works well.

@YeagerTheCat that’s great news, at least you have the NVMe working!
When trying the NIC - did you see in the system (eth1 etc)?
Mine works fine powering the board but can’t see it in the system, nothing even attempting to load in (dmesg). Tried powering via usb today and plugged into a nonPOE switch, still nothing :frowning: pretty sure a dud board?!

Can you provide more details about this model ? And the purchase link?

Absolutely. I haven’t done any sort of real testing with it yet other than to see it, partition it and format it etc.

The picture is misleading because it is actually a small size version. THe m2x board has screw holes for the various sizes and it fits fine. I will have more to report tomorrow.

The VIM3 is interesting to me because it actually has a proper solution for an SSD, something that is a little unique. I see the other posts about PoE and I haven’t had luck so far myself with that as reported, but I did buy more than one M2X board by mistake so I will be happy to try the second board and see if PoE works on that one. THe m2x board itself is pretty thoughtful in terms of its construction - I think I have said earlier, but I am pleased by it.

1 Like

I will have another look again tomorrow for PoE and as I mentioned in a different reply, I have a second board to try. I don’t need PoE and didn’t get it for it, but it is pretty cool if it worked and we might have a reason to be interested. Powering from Ethernet simplifies installation no doubt. Be back to you tomorrow.

For PoE, you also need a router which support PoE, normal router can’t work.
And make sure your LAN cable also supported.

Assuming a compatible cable, would a PoE injector also work?