VIM3 and LibreELEC (Linux 5.x) Colour Issues

Hi there

I flashed my Vim3 Pro to AndroidTV and didn’t like it so i’ve now decided to go with LibreELEC.
However now that I’ve got the OS installed the colour is really funky, pink text and purples.
I haven’t’ connected up storage to it but it looks really wrong. I currently use Kodi on another device with the same theme and it’s Black and Blue’s.

What have I done wrong to get this. The colours look fine when booting up and it was all good when I had AndroidTV installed.

What do I do?
I tried both of the VIM3 imaged for the release date and both are the same.

I followed this link to set it up.

if u reel need watch movie !?-
mainline kernel with libreelec not best choose because still have a lot of problems! check other distros with legacy kernel :wink:

1 Like

It’s a known issue that @narmstrong is looking into. It can be resolved by using mainline instead of vendor u-boot, but that’s not currently present in the LE codebase. I’m waiting on Neil to release a bundled fip package for u-boot … soon hopefully.

1 Like

Roll back the firmware to stock Android that comes from the factory and all colors will work correctly. This is amlogic’s u-boot curve problem, they made changes with bugs and don’t want to fix them.

I test all LE and Armbian systems on VIM3 (a311d and s922x) and everything works fine with stock u-boot with kernel 5.x (without using the bastard and crooked old kernel 4.9 with a bunch of security holes).


So to this Firmware?

I believe the issue is present when using 5.4-rc kernels (which contain newer HDMI code) and vendor u-boot, and it is not seen with older <= 5.3 kernels or when using mainline u-boot with the current 5.4-rc or newer kernels. In other words, even if you restore factory u-boot to the device you’ll hit the problem. It is definitely present for me on VIM3 and VIM3L using factory u-boot and 5.4, and the issue first appeared with 5.4. I have been meaning to try reverting the simple framebuffer changes to see if that makes a difference, but I’m tied up with day-job work and don’t have time at the moment.

I’m testing (s922x\a311d - VIM3, N2, AM6, s905x2 - x2cube etc) all 5.4.x kernels and the most recent versions of next, when using u-boot-2015 (with a build date of July-August 2019), everything works without problems. All colors are correct in all LE and Armbian builds. The problem only appears when switching to the latest version of u-boot-2015 (which AML broke and did not fix).
What firmware do you have installed in VIM3 ?

I have a long time ago installed the LE version in eMMC and so I do not know exactly the firmware version number in which the normal u-boot is 2015, but here is the output of the u-boot version and the output of the kernel version 5.4 , with which I have no problems with not the correct Kodi colors. The only thing that in this version (with this kernel 5.4) does not work DEMO PVR (when playing a test clip, the whole screen is green). By the way, I rolled back to the Assembly with the 5.3 kernel, everything works there and with the new u-boot-2015 and DEMO PVR works.

U-Boot 2015.01-g11ea16c-dirty (Jul 04 2019 - 09:44:47)

LibreELEC (community): devel-20191025102633-6e9040d (AML.arm)
LibreELEC:~ # uname -a
Linux LibreELEC 5.4.0-rc3 #1 SMP Fri Oct 25 11:03:42 MSK 2019 aarch64 GNU/Linux
LibreELEC:~ #

I looked quickly, and the newer amlogic u-boot enables HDR from u-boot, and HDR should be disabled when loading mainline linux at some point.


Okay, i think i’m going to need some help here getting the back to the default Android.
I’m getting super frustrated trying to figure out how to flash my vim3.

As per @hyphop suggestion I’m trying to flash back to Default Android and then I’ll put CoreElec on my VIM.
However I’m really struggling to flash it back.
I’m not sure if I’ve for the right image because currenlty i have the AndroidTV and i can’t get it off.
But i’m also not sure I’ve got the right image, as i want to erase the flash.
I’ve tried every application out there and i can’t get it to flash to the Default Factory Android.
Could some one give me a link to the img and what method they used to flash it?

Try leaving the current firmware and check for the latest LE images (20191113).