VIM1 issues with Ubuntu 4.9 eMMC

#1

According to Gouwa’s suggestion, creating a topic for my VIM1 related problems with Ubuntu (xfce-bionic_Linux-4.9_armEMMC_V2081030)

  1. Bluetooth not working
    unsuccesfully tried BT tethering and connection to the speakers.
    connection to speaker sometimes succeeds, but sound is jerky, --> BT totally unusable

  2. Screen rotating not possible
    that’s a shame, because VIM would be a perfect digital signage device (portrait mode often needed)

  3. RTC useless - saving time to it is impossible (of course the battery is connected)
    Answer to hwclock -rD is either
    “No usable clock interface found” or “hwclock: select() to /dev/rtc0 to wait for clock tick timed out”
    Have noticed that fake-hwclock is installed and enabled.
    That should be disabled, once the real RTC starts working…

3 Likes

#2

@Frank Please followup.

0 Likes

#3

Hi @ufneeme ,I am frank,I’ll try to reproduce and sovle it as soon as possible.

2 Likes

#4

Hi Frank, any success?

0 Likes

#5

Yep, the problem is in processing, we already can let the Bluetooth work, but still not quite stable, will update more soon.

Good day!

0 Likes

#6

Hi @ufneeme , the cause of the problem has been identified. It will take some time to resolve.There will soon be a new version of firmware.I’ll come back here and tell you.

0 Likes

#7

thanks, waiting with interest.

0 Likes

#8

Hello @ufneeme

Can you please check with the bluetooth audio?

VIM1_Ubuntu-xfce-bionic_Linux-3.14_arm64_EMMC_V20190411

VIM1_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20190411

Thanks.

1 Like

#9

with 3.14 I could not find the way to activate bluetooth,
but in 4.9 BT works very well now, thanks!

1 Like

#10

Hi @ufneeme,with 3.14 could not find Bluetooth switch? or Bluebooth Manager ?

0 Likes

#11

Hi @ufneeme ,I check the bluetooth with 3.14 just now,I can connect to my Bluetooth speaker.Can you take a screenshot?thanks.

1 Like

#12

my problem with this version of 3.14 is KODI autostarts and I cannot find a way to get out of that

0 Likes

#13

Please check the upper right corner to select XFCE desktop on login prompt.

0 Likes

#14

Hi @ufneeme , you will see this button in the upper right corner.


thanks.

1 Like

#15

Yep, have found that.
The thing that puzzles me now is that during the installation of some additional software, the bluetooth icon in the upper right corner is lost, with both 3.14 and 4.9. BT Adapters and BT Manager selections are still present in Settings Manager menu from the upper left corner, but they do not react any more.

khadas314ur

In this state I can still use bluetooth tethering, called n_Oppo (internet for Khadas from my android phone is working). But I cannot find anything for BT audio.

Need to do replay the installation script step by step, to find out what is going on.

0 Likes

#16

Can it be used after reboot? And what additional software is installed ?

0 Likes

#17

reboot does not help. software installation script follows:

pt purge -y libreoffice*
apt purge -y thunderbird*
apt -y autoremove
add-apt-repository universe; add-apt-repository restricted #sellest sõltus python
add-apt-repository multiverse
apt -y update
apt -y upgrade
apt -y install build-essential libpq-dev libssl-dev openssl libffi-dev zlib1g-dev
apt -y install libcanberra-gtk-module
apt -y install libcanberra-gtk-module libcanberra-gtk3-module
apt -y install libtool unclutter
apt -y install lshw mtr-tiny
apt -y install ckermit minicom
apt -y install sqlite3 xdotool
#apt -y install python3-gdbm
apt -y install python3-dateutil
apt -y remove lirc
apt -y autoremove
apt -y install vnstat
apt -y install tcpdump
apt -y install sleepenh
apt -y install python3-pip
apt -y install python3.7
apt -y install python3.7-dev

0 Likes

#18

I try to install the list and check it now.

0 Likes

#19

Hi @ufneeme,I installed all and reboot,the bluetooth works well.But you’ve always used root.So I wonder if there is any misoperation.It’s just my guess.Can you try it again ? Thanks.

0 Likes

#20

Hi @ufneeme ,I check it with the installation script again.The bluebooth works well.So I don’t know what changed it.

0 Likes