VIM Android Nougat V171028 ROM Release

Here release the Android Nougat ROM

Check Firmware Page to download the ROM.

ROM Infos:

  • ROM version: VIM_Nougat_V171028.7z

  • MD5SUM: 28845c511f8aeb1c1b71818560e29990

  • The ROM is for EMMC installation only

Change Log

  • Update SuperSU to the version 2.82
  • Fixup stucking on boot animation after updating SuperSU
  • Fixup the bug of resulotion display menu
  • Add support for HID multitouch panels
  • Add support for some Apple HID devices which less or more break

Upgrade guidance:



many thanks for it! supersu works. another question. is there a chance to use a usb-gps-mouse in android? did’t find any information in google about it …

I get Launcher3 keeps stopping error after upgrading to this. The only option available to me is close app. Please help.

So Android is still suffering from bugs, i couldn’t use older Android builds with message “system ui has stopped”, today i have tried to set up Kodi, i received a message “Kodi isn’t responding”, with close, wait and send feedback options to choose.

I couldn’t click on any of these options, this message was looping every few seconds, i had to reboot Vim to be able to control it.

I can’t believe you haven’t solved this, there is too much serious work for such a small team,

I do believe the only option to make use of Vim, is to install Libreelec for S905x devices, at least it will be usable as media center.

I don’t see improvements, Android and Ubuntu aren’t getting better, they all suffer from day one bugs, nothing has changed by now.

1 Like

I have successfully boot in libreelec. And between libreelec and khadas android, there is no competition. Khadas android is totally useless. I cant believe the time i spent figuring out what i did wrong. Khadas android have too many problem, its not even funny. You cant even use it for kodi reliably. For those want to try khadas android, if you have problem, know that its not you.

1 Like

Is it possible to upgrade using Upgrade on Windows PC via SD burning card?

Tried multiple times. Screen only shows VIM logo.

It can be upgraded with SD burning card. You can refer to Upgrade Via a Burnning TF Card
By the way, don’t connect VIM Type-C port with your host PC.

Ah so thats why. Gonna try that now.

Lesson learned. Unless you want to connect to pc using USB-C, dont power Khadas Vim by connecting to PC USB.


It seems that the original Netflix APK (with every perms set on) does not work.

I get the loading screen, then black screen.
Tried uninstall, reinstall the APK, reset cache, reset perms, still doesn’t work.

Netflix worked fine on Marshmallow, do you have any information about that ?

By advance, thank you.

Which Netflix APK did you installed?

This one :

netflix works only on Vim_Nougat_Root_170421 on other nougat roms does not work black screen. i do not update the last rom for that reason. i already reported the problem in another thread.

1 Like

We will release new update ROM for both VIMs, and will fixup the issue.

Thanks for the feedback.

1 Like

@gianni : Thank you for your advice.
I will install that rom and wait for update.

@Gouwa : Thank you for this information, if you need any help for testing the fix, don’t hesitate to ask me :slight_smile:

Can you provide more details about the fix?
Because it is not SuperSU apk itself that is asked to be updated, it is the UNIX su binary.
Currently I spot su as /system/xbin/su but 2.82 is a, so called, ‘system-less’ root and would want to place su binary (and other files) in sub-directories of of /su (like /su/bin /su/lib etc…).
Question: Has anyone allowed SuperSU to update the su binary? If so, did it arrive in /su or /system?
I am hesitant to allow the update.
Note that SuperSU 2.82 works on V171028 without the requested su binary update, but ideally I would like to get rid of the warning and be sure to proceed with su binary update.

You can refer to below commit

1 Like

@Terry . thanks!
I went ahead and updated SuperSU’s UNIX su binary on 3in1 firmware.
FYI: the new su ended up in /system/xbin/ so it is not a ‘system-less’ root.
Buy it works just fine!