USB port malfunction

OI, Gouwa!

  • Ja experimentei o mouse nas duas portas e em nenhuma funcionou.

  • Ja experimentei pen-drive e um hd usb externo nas duas portas e não funcionou.


No idea at the moment, double confirm with you again:

what you tried is USB device like this(USB Disk):

Not someone like this(HDD may need external power supply):


If you have tried out the 1st one above (USB Disk), maybe you can contact the custom service where you bought for further details.

I have VIM1.
Suddenly, I ran into the same problem with the usb host. None of the usb ports works (2 USB, 2 USB devices on the GPIO header). 2 USB ports on the rear panel are normal (5 V), but no more (no devices detected). According to the USB HUB circuits, the U16 chip (FE8.1). It seems that there is a short circuit between the terminals VSS and VDD3F, and the resistance is about 2 ohms. Currently, only the USBOTG port is working.
The next step is to unsolder FE8.1 chip (U16) from the board and check it separately

Infelizmente tive o mesmo problema, possuo o aparelho a 4 meses … Muito pouco para dar problema de curto circuito em placa …

Which model do you have?

Vim1 I have the same problem. Its used now only for tv box hdmi and controlled by remote only

Check your PM for the instructions to move forward.

By the way I’ve noticed another problem(or doubtable design) with USB:
you can’t use GPIO USB and usb socket the same time. If you have a USB device (in my case it’s an external hub) connected via GPIO and you plug in something to the according USB socket on the front - USB device connected via GPIO disconnects.

What kind of usb devices you connected for both GPIO USB and the USB port?

huawei lte modem to usb port, and 7 port Termius hub to gpio. I plug in the modem - hub disconnects. I pull the modem out - hub connects :man_shrugging:

Hello, is the hub self powered?


You’ve asked a rhetorical question. Of cause it is self powered with 12V 3A. I connect it to HUB_DM1 and HUB_DP1.
Can you imagine 7 usb devices along with a hub itself powering via a single 500mA usb port? Of cause not.

Yes, one would think.:grin:

I have a, non-powered 4 port hub. I don’t run USB connected drives with it. Handles 4 HIDs, or a mix of HIDs plus thumb drives and/or card readers just fine, connected to 500mA USB port. So maybe not 7, but possibly 5. :rofl:

But yes, I get your point.

Hi everyone recently i purchased vim1 board and m facing same problem. My both USB Ports failed to detect non of any things but else giving power.

Hi Waqas:
Can you take a high resolution picture on the side USB port and post here:

Both USB ports showing above 5 dc volt. However ports unable to reconigze anything. So i can’t move forward with same problem after installing all versions

of vim1.

Kindly make a video to detect the usb ports not working problem with solution.

@Waqas-Kashif thank you for your photographs. According to our engineer Gouwa, it could be that one of the pins of your USB-port has been “pushed inward”.

Please send us a sharp, magnified image of the USB port. Preferably from at least 2 angles, so we can see the depth of the pins.

I pushed the pins outwards but still same problem. Then i decided to check board with multimeter at cotnuity mode and found that only capacitor # 135 is not showing any reading value or any volt etc. ?