USB port malfunction


#1

Good afternoon.
Today, both USB ports have stopped working. No device is detected. Used only to connect a mouse. Is it possible to get support or do I have to buy a new device?
Vim 8 gb not pro
E-E18-A4-101
202745601
T0036201612150000


#2

Hi, Tony:
Can you kindly try with more USB devices like:

  • USB Disk
  • USB Keyboard

If your problem doesn’t get resolved, please take some high-resolution photos on the USB ports and post to us, so we can locate your problem more easy.

As you said that both the two USB pots stop working, so a photo on the top of VIM board will be helpful.

Happy to serve you.

Thanks!


#4


#5

Tried working 2 usb flash, usb mouse


#6

Hello 5a1n7, I am curious. Do you have a powered USB hub you could use to test the ports? The USB port’s 5 volt is fuse protected. If the fuse was blown, the port should still work using powered hub.


#7

Hi,

I have similar problem. For me use of usb hub with external power supply has not helped.

BR,
Eugene


#8

Hi, xslip2:
Did you mean that you only with problem when using USB Hub and works if connect directly to USB port on VIM, right?


#9

Nope. It doesn’t work for both options.


#10

@5a1n7 Tony, any update?

@xslip2 are you a developer or normal user? I will figure out the new testing method for you.


#11

Hello, nothing new, usb hub with power did not help. Looks like i need to change the device


#12

Hmm, I’m IT dev, but not in field of unix. However I’m familiar with shell scripting/c.


#13

Can you try to follow the instructions to help catch the printing log and post to us?

1) Setup Serial Tool
2) Power on the VIM and plug any USB device, then catch the printing log.

The system should detect following similar printing(A TOSHIBA USB-Disk here):

[  116.143541] usb 1-1.3: new high-speed USB device number 3 using xhci-hcd
[  116.246779] usb 1-1.3: New USB device found, idVendor=0930, idProduct=6544
[  116.246896] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  116.246976] usb 1-1.3: Product: TransMemory     
[  116.247051] usb 1-1.3: Manufacturer: TOSHIBA 
[  116.247126] usb 1-1.3: SerialNumber: C412F52D6C8EC1203002AE2C
[  116.250567] usb 1-1.3: ep 0x81 - rounding interval to 128 microframes, ep desc says 255 microframes
[  116.250724] usb 1-1.3: ep 0x2 - rounding interval to 128 microframes, ep desc says 255 microframes
[  116.253025] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[  116.267240] scsi0 : usb-storage 1-1.3:1.0
[  117.518967] scsi 0:0:0:0: Direct-Access     TOSHIBA  TransMemory      1.00 PQ: 0 ANSI: 4
[  117.534744] sd 0:0:0:0: [sda] 30310400 512-byte logical blocks: (15.5 GB/14.4 GiB)
[  117.535034] sd 0:0:0:0: [sda] Write Protect is off
[  117.535050] sd 0:0:0:0: [sda] Mode Sense: 45 00 00 00
[  117.535329] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[  117.537690]  sda: sda1
[  117.539327] sd 0:0:0:0: [sda] Attached SCSI removable disk
root@Khadas:~#

#14

Boa tarde!!

Sou um usuário comum uso o vim como box tv, acontece a mesma coisa comigo as postas USB não funcionam, utilizava o vim com um mouse e um controle do xbox 360, agora ele não reconhece mais nada.
Ao ligar o VIM ele inicia o android mas não funciona as USB.


#15

Hi, Josuer:

Does your issue got resolved?

Well, let me paste Google Translate of your issues details here first :smile: :

Good afternoon!!

I am a regular user I use vim as box tv, the same thing happens with me the USB posts do not work, I used vim with a mouse and a control of xbox 360, now it does not recognize anything else.
When connecting the VIM it starts the android but USB does not work.


#16

Boa tarde!! Ainda não continua da mesma forma. O vim funciona normalmente mas as portas USB não.


#17

Does the USB port works fine with other USB devices like USB Disk or USB mouse?

Google translate to Portugues:

A porta USB funciona bem com outros dispositivos USB, como disco USB ou mouse USB?


#18

Não funciona nem com mouse nem com pendrive, mas quando conecto o mouse o sensor do mouse acende mas não funciona.


#19

Google Translate:

It does not work with either mouse or pendrive, but when I connect the mouse the mouse sensor lights up but it does not work.

Can you kindly take a photo when you plug a USB device in the VIM? and kindly try both the two USB ports on your VIM.

Google Translate to Portugues:

Você pode tirar uma foto gentilmente quando você conecta um dispositivo USB no VIM? e experimente as duas portas USB do VIM.

Thanks!


#20

Boa Noite!!
Ainda não consegui resolver meu problema, portas USB não funcionam, atualizei o VIM para o Android OREO mas continua na mesma.

Conforme foto abaixo a luz do mouse acende mas não funciona, pen drive não funciona, teclado não funciona, o que fazer???


#21

Hi, Josuer:
Kindly help to reply below questions one by one:

  • Does your USB mouse don’t works on the two USB ports?
  • Have you tried USB-Disk on VIM?

Thanks!