Unable to boot and unable to flash

I have been unsuccessful in trying to flash my Khadas. I tried different method just to get it work. The last method I tried is flashing without erasing flash and bootloader. While the flashing is success, I cant boot the device. When I connect to USB Burning Tool, the device is not detected. I tried holding power button when powering the device, still USB Burning Tool cannot detect.

Did my Khadas bricked? WHat should I do? Wasted a lot of my time on trying to flash already.

Can somebody tell me if my device is bricked? So that I wont waste my time hoping to get it fixed.

Do you have usb-uart tool? And you can try to update your VIM2 device with other PC.

Tried updating on other pc. Some result. Unable to detect device.

Assuming I have USB-UART. How do I use it? And why does this happens?

You can provide some update informations for me if you have usb-uart tool.
About how to get useful printing log, you can refer to this.

Hello, Some things to try. Starting with the VIM2’s power disconnected and no sd card in the slot, are you using the update method seen here(disregard references to SCV3 and droidscript)? If so and it still isn’t working, you may have some success using the M-register method, though I have not tried it myself.

I always use the USB Burning Tool configured as shown in the following picture.

You may also want to try manually re-installing the Amlogic Worldcup Driver, the exe file is found in the folder where the USB Burning Tool is installed. Should be in a folder named WorldCup_Device. Look for “InstallDriver.exe” - Run it as administrator.


Tried the method holding power button before providing power. doesnt work.

Just something I noticed recently, after the last win10 update from Microsoft, I was not able to put the VIM in loading mode. I had to re-install USB Burning tool, after that it all worked again.

1 Like

Already tried reinstalling usb burning tool. doesnt work. install on other pc, same result.

Did you try the M-register method as RDFTKV said above?

And does your VIM2 device still works now, I meant I want to ensure which issues your are meeting:

  • Can work, but just cannot upgrade
  • Cannot work and cannot upgrade


Havent try mregister.
Device doesnt work. When powered, only red light visible. nothing shown on tv. unable to connect to usb burning tool(cannot detect)

Double-confirm with you again: which model you have? VIM1 or VIM2?

As VIM2 only have blue and white LEDs, don’t have red led :wink:

May be you can take a photo to us

My bad. Its Vim 1. https://photos.app.goo.gl/BUAR3v9hrctAY05f1

Anyway, there is no hdmi signal. What should I do? Tried m register. no hdmi signal.

can somebody move this thread to vim1

Did my khadas vim is dead?
I cant get any signal from hdmi.

Is it possible for khadas vim to die?

My problem is that there is no signal detected in tv. Please advise.

Please advise. If my khadas is dead, i dont want to waste my time trying to make it work.

As you upgrade VIM1 with VIM2 ROM, so your device cannot boot at more. And now the only way is that use the M-Registor way to let your VIM boot into upgrade mode.

Good day!

tried m register. nothign happenm