Unable to boot and unable to flash


Shouldn’t be, can you kindly confirm again that you operate in the right way?


Shorted m register with screw driver. then press reset button. no signal.


to boot into upgrade mode, i must be able to boot first. it seems my khadas is unable to even boot.

So tell me, did i wasted my money and time on this?



Be patient, kindly try again.

Make sure the screw driver with good conductivity, recommend you try again with a tweezer

Good luck!


Please dont give me false hope. Ill try again later.


Trust us, we will back you!


Since you have a VIM1, please note M-Register contacts are as shown here…http://docs.khadas.com/images/MRegister_ShortCircuit.png


Thats the M-Register that i have been trying to short all this time.


Can you take a photo how you short the M-Register?


This is how I short M-Register.
As usual, nothing happens. No signal from HDMI. Power source is usb charger. Memory card is burned with VIM_Nougat_V180210.7z using method described in http://docs.khadas.com/bootcamp/UpgradeViaTFBurningCard/


What should happen if M-Register worked correctly? Should there be HDMI signal?


Tell me. Am I wasting my time?


Try this:

  • Plug-out the TF Card first
  • Try with a tweezer instead the tool you used now to make sure it did short-circiut.



What happen if it succeed? Would I get HDMI signal? How do I know it works?


If you did this, the USB-upgrade-tool on your PC side should detech your VIM device as upgrade mode, more details at:


I see. So thats mean i need to connect to my pc usb. Im currently connected to plug power usb.


:rofl: That should not work…


I am now able to boot in khadas. Thanks.

Heres how I fixed it.

  1. Remove sd card.
  2. Power on Vim by connecting USB to PC.
  3. Open USB Burning Tool.
  4. Use a tweezer (I use test pen) to short-circuit the two pads of M register and without release. http://docs.khadas.com/images/MRegister_ShortCircuit.png
  5. Short press Reset key and release it to boot into upgrade mode. Wait about 10 seconds.
  6. If successfull, Khadas VIM is detected in USB Burning Tool. If not detected after 10 seconds, try again shorting M Register.


Hi Syaiful:
Make sure you did the right steps:

  • You connect a USB-C cable to your computer/PC and VIM device
  • Short-circiut the M-Resister via a tweezer or some other tool
  • Press the Reset button
  • Check the upgrade tool on your computer/PC and go forward to upgrade a new ROM

As your problem last quite long time, if aboved still not works, I think maybe I can take a video call and try to figure out the problem.

Good luck!


Hi Gouwa,

It works. Now enjoying brand new android. Happy camper.