Two minor features not working

After successfully applying both the recent XMOS and MCU upgrades, I noticed that two features are not working:

A. The single push to pause playback and restart playback in General Mode, and
B. The skip ahead or move back to the next or previous selection in Track Mode

I’m not sure if this started with the upgrades or was there before as well as now.

Any advice you can offer for fixing this is welcome - thank you.

@rhst1 @Gouwa @Eric68 Please help this .

Hi, we have tested the two functions you mentioned after upgrading the XMOS and MCU firmware to v1.2; the Tone2 Pro continues to function normally. You can watch the upgrade videos about how to upgrade the XMOS and MCU firmware. Please ensure that you’re using a Type-C USB cable for the XMOS update via the DFU tool, and use the ST-link v2 hardware tool for the MCU upgrade. :smiley:

I believe the upgrades were successful. See the following images:



The features are missing when playing from Tidal and from Foobar2000. Alternatively, I have not tried the features when using a CD player (HDMI to USB). I am thinking that perhaps the features only work when there is a device like a CD player to accept the pause and change track features?

Both features are working for me post upgrades. Watching a Youtube, pause/play works.
Using Foobar2000 to play files on a Win10 laptop, pause/play works. So too does track -/+.
I do not know what is causing your issues, but in my experience, a log stating a successful upgrade/update is not always proof of a successful upgrade/update.

Thanks RDFTKV,

Should the features work both before and after upgrade or only after upgrade?

I know the play/pause worked prior to the update, as well as after.
The track -/+ I don’t recall from prior to the upgrade, but it works after.

So if the play/pause worked prior, then whether or not my Tone2 has been upgraded is not the issue. For some reason, the play/pause is not working, whether it is version 1 or version 1.2

It could possibly be operator error, although I have tried various push time lengths to initiate play/pause with no response regardless of the variation.

This video gives a good example of function.

In an unrelated thread, a user disabled some T2P functions as they found it was preventing their PC from sleeping. Have a look to see if any T2P related USB HID functions have been disabled on your PC somehow.

Not sure it would matter, but are you using Window’s native driver or the T2P driver?

That is the video that alerted me to not having the functions.

Am using the Khadas USB driver.

Don’t think I’ll proceed down the USB HID rabbit hole after taking a brief looking using the Device Monitoring Studio app.

Maybe one of the Khadas Team can help. @Eric68 may have solution.

I have some questions need to confirm with you below.

  1. Are you sure that the right MCU file is download into STVP? if you download the right file,you can see the hexadecimal data in the buffer. You can check the data in first several rows if it is same with you.

    2.Are you sure If you upgrade the firmware successfully?if you success to upgrade,you can see that 5 RGB lights should be shut down and then turn on.
    3.Can you feel that the button can be clicked well? May be the button got stuck. The right way to click the button is shown below.
1 Like

Thanks, Eric.

There seems to be some question whether or not the device has been upgraded, but whether it is or is not, the play/pause single push should work. Since it does not (nor does the change track function), I’m wondering if the unit may have a defect?

Another strange thing noticed starting today is that when listening to Tidal, sometimes a track will stop playing about half way through. This has only happened twice. I don’t know if it is an issue with Tidal, the PC, or the Tone2.

Is there a way to test the MCU upgrade by using the USB port in a way that was not possible before the upgrade? If yes, this could be a way to verify whether or not the upgrade happened correctly.

Just reflashed the MCU upgrade, but there is no change from what was reported above.