TS050 not functional on Linux

Which Khadas SBC do you use?

Khadas VIM3 Pro

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

Version 230425 from Khadas

Please describe your issue below:

The TS050 Touchscreen does not work on Linux. We have full functionality on Android but on Linux it just displays a static image. We have upgraded the firmware as recommended.

1 Like

Hello @Tgmstriker

Do you use the desktop or server image? Can you see the Khadas logo when you power on the board?


I’m going to be passing this off to a colleague of mine. However, I believe it is the desktop version. We see the Khadas Logo appear using a standard monitor but nothing on the TFT screen. Here is a picture of our TS050.

Using the desktop image, Khadas logo shows on touchscreen on startup, but after boot cycle the screen goes to black/static/white

Hello @Tgmstriker

Please double check with this image: https://dl.khadas.com/products/vim3/firmware/ubuntu/emmc/vim3-ubuntu-20.04-gnome-linux-4.9-fenix-1.5-230425-emmc.img.xz

Hello @MSmith

Have you remove the HDMI cable ? You need to remove the HDMI cable if you want to use the screen.

HDMI Cable has been removed (shown in the first picture).

In general, what is unique about the image that would make it work / not work? Is it enabling things like how you have to enable the extra UART / I2C Ports on the GPIO header? Looking at the schematic the board brings out multiple channels on the MIPI-DSI connector. Are you just enabling the correct ones to interface with the screen?

Beyond just finding the correct image, we would like to know specifically what is being changed in what file to enable the screen.

We do not use the emmc image, we use the generic but we have tried this generic image
The image had the same issues as in the previous posts.
We have since tried the emmc image but with an SD card, does it matter if we specifically use an emmc card? If we cannot use emmc is there a way to configure the SD card image to work?


  • Please re-burn the board with an Android firmware, I’m guessing it’s a broken screen. Please help verify!

  • I use the same Ubuntu firmware as you and the screen works fine. If the firmware does not support screens, it will not display a snowflake screen

We have full functionality on Android.

Please use this firmware:

That firmware works when we install it on the emmc. However, we use the SD card. Neither image works on the SD card. What is the difference in the OS on the emmc and the OS on an SD card?


Try this firmware

Run the following command to erase eMMC. the above issues will not occur when using Sd firmware.

  • Refer to this guide to setup the Serial Tool for your VIM.
  • Press the space bar at startup to stop automatic startup. This step will enable the VIM to enter u-boot mode.
kvim3#store init 3

This image did not work with the touchscreen on an SD card

Can you verify the touchscreen works with
using an SD card and if it does, did you make any changes to settings for the OS?

Hello @MSmith

To use the SD card image, you need to erase the system on eMMC. Please check:


After erase the eMMC, the touchscreen should work with SD card image.

First I tried using this.
This converted our image with all software into the emmc which worked but we would prefer it to be on the SD card.
I did manage to erase the eMMC by interrupting a fresh eMMC install. Which allowed it to boot from the SD card and the touchscreen worked.
Lastly I discovered burning our image to the eMMC, then continuing to use the SD card allowed the touchscreen to work.
I attempted the CLI method for erasing the eMMC and it did not work. it still booted into eMMC.
The windows Serial guide leads to a required driver that says 404 not found. The only method that worked is Interrupt Mode. Which is basically just corrupting the image on the eMMC so it cannot boot. Is there another way to erase the eMMC?