TS050 not functional on Linux

Can you explain why the eMMC matters so much? It looks like MSmith is finding a solution but hes reported other weird behavior like UART3 on the GPIO header doesnt work now that the Touchscreen. We want to use this board in a fielded production system so we need to understand the details as to why the eMMC matters and what its impact is on the SD Card.

Hello @Tgmstriker

Because when you bootup the SD card image it will use the u-boot from eMMC (eMMC has higher boot priority) if there has image in eMMC, so if the u-boot is not compatible with SD card image then it will has issues.

We suggest to use the u-boot from SD card image itself, so you need to erase the eMMC.

Understood. MSmith has been able to get full functionality of everything now. However, he still cant uninstall / erase the eMMC image. So far the best he has been able to do is corrupt the image on the eMMC so it cannot boot.

Is there another way to erase the eMMC? He has tried:

  • erase the eMMC by interrupting a fresh eMMC install. Which allowed it to boot from the SD card and the touchscreen worked.

  • attempted the CLI method for erasing the eMMC and it did not work. it still booted into eMMC.

  • The windows Serial guide leads to a required driver that says 404 not found.

Once we have that figured out we can mark this as solved!

I also used Krescue which has a feature to erase eMMC. This worked but it caused a strange error where the image was skewed on the screen while booting up. It also took longer to boot up.

@Tgmstriker @MSmith
Go to the Uboot CLI and run the following commands

1 Like