Touchscreen + VIM3 on Android does not work

Hi, I recently got the LCD touchscreen TS050.
I start VIM3 from eMMC with the last Android with only the screen connected and it shows no signs of life. what could it be?
is it lcd or vim3 problem? I read at the forum thread for Edge that LCD shall work with Android out of the box.


Many thanks!

As Gytis Mentioned in this post Android doesnt seem to have Touchscreen driver

So maybe try Ubuntu and test the Touchscreen and LCD. It should work.

Indeed - try with Ubuntu Bionic Xfce edition (already built or from sources) - it certainly does have touch screen driver.

I didn’t try with pre-built Android Pie, but with Pie built from source TS050 shows no signs of life.

Sorry to jump in on this conversation, im just curious and trying to figure out as much as I can before I buy a VIM or Edge.
Are you guys saying that the Android images that are provided dont have any touchscreen drivers at all?

I tried to start VIM3 with two versions:

  • [VIM3_Ubuntu-xfce-bionic_Linux-5.3-rc4_arm64_SD-USB_V20190830]
  • [VIM3_Ubuntu-xfce-bionic_Linux-4.9_arm64_SD-USB_V20190830]
    Both work well with HDMI. LCD touchscreen is still dead.

I am wondering whether the screen is defective? Or the VIM3 is defective?
I requested Khadas on Aliexpress and no answer so far.
I am new in Linux/Android, but I am sure that Khadas should not sell LCD Touchscreen for VIM3 if there is no OS, which supports this function. At least they could declare it in the listinng.

Did you unplug HDMI? You need to have touch screen connected and HDMI disconnected.

I’ve tried on my VIM3 Pro with this image and TS050 worked: VIM3 with Ubuntu bionic + Touch screen TS050

I am also a bit worried TS050 is being sold with little compatibility at the moment and VIM3 is actually positioned as dual display device (RPi 4 supports dual monitors via two miniHDMI ports) whereas at the moment only one of the displays work… But I trust Khadas team will fix that :slight_smile:

Yes, I did disconnect HDMI. Touchscreen did not even show the Khadas logo by the start.

Please try:

https://dl.khadas.com/Firmware/VIM3/Ubuntu/EMMC/VIM3_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20190830.7z

https://dl.khadas.com/Firmware/VIM3/Ubuntu/EMMC/VIM3_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20190830.7z

Does VIM3 start?

Because if you accidentaly reverse cables connecting TS050 to VIM3 the latter simply doesn’t start at all (probably a protection feature).

There is no any manual or instruction from Khadas how to connect the screen, therefore I used the picture on the product listing to understand the side-layout. I connected the screen as on the pictures in the posts above. It should be right.
I did not flash eMMC, only SD card with Ubuntu xfce version. But I assume it doesnot matter from which memory does it start. I tried both 5.3 and 4.9 versions. The VIM3 starts, but only HDMI works. Touchscreen even does not show the KHADAS initial screen. No signs of life. Therefore I assume it can be defective. I did not getany help or response from Khadas on this and therefore will be communicating with them through Ali express buyer protection.

Hello @koaly

Here is the connection documentation

https://docs.khadas.com/vim3/ConnectLcd.html

Only 4.9 support LCD. And if you want to use LCD, you have to remove the HDMI cable.

Thanks for updating the docs. It does look different from the real item received. There are two cables instead of one. With separate cables there is always a chance to connect it with the wrong side. What will happen then? I’d better use the product listing pictures. This one is missleading.
I would ask to include also description of requirements, conditions how to make it working and links for appropriate FW.

I got the LCD working with 4.9, but I do not agree with your wording. LCD works only if the Ubuntu 4.9 installed in eMMC. If you do not have 4.9 on eMMC (e.g. Android on eMMC), LCD will not work.

Frankly speaking, only LCD makes sense mainly for Android, because otherwise everything is too small to use touchscreen.

With the Edge, TS050 works out of the box for me, but only with the MIPI firmware listed in the “quick and dirty” method of the wiki. https://docs.khadas.com/edge/ConnectLcd.html with ubuntu, only the display works, not touch. Both work when I use a hdmi touch screen.

Actually, I remember my TS050 not working at all either when I first got it and it turned out to be the usb c cable that I was using. When I tried a different cable it worked, I presume it wasn’t providing enough power despite the board being on. Maybe that’s your problem?

Thanks for the hint about the power. I use Khadas 24W power supply and it has been found already that the problem is in the Firmware. Android version from Khadas does not support MIPI screen so far and only Ubuntu with 4.3 kernel does, when installed on eMMC. In all other cases no chance to make the TS050 working. So, it makes no sense to buy TS050. I did it only because I trusted the listing from Khadas. Such a naive.

Hey don’t be disappointed yet. They have promised to release the updated Android firmware with mipi support soon, so its just a matter of time.

Cheers.

1 Like

SD image use the u-boot from Android, so the Android image need to support the LCD, but android still has some issues about the LCD, when we fix this issue will release the new image.