Tone2 Pro - Firmware v1.2 + MCU Update

Thank you so much. The app just wouldn’t open on my Macbook Pro even in Admin mode and unlocked mode, firewall off. I tried everything.
But it worked like a charm on my 11 year old iMac once I pointed it to the bin file. Just a few seconds and it was done.
Hope this means I don’t have to fiddle with that StLink V2 .
Thanks again. And its a great product.

1 Like

May I know which model MBP you are using now?

Actually, still needed :stuck_out_tongue_winking_eye:

You can follow the video guidance and just skip the XMOS firmware upgrade part. Please let us know if any problem there.

Sorry for the inconvenience!

Its a MBP 13" 2018, with 4 usb C ports and 8gb Ram. Big Sur v11.6. When trying to open the DFU app it says I don’t have permission to open the app. Contact your computer or network administrator for assistance. I have unlocked the app from and set my name for read and write.
I will try running the other script on both this and the iMac and see what happens.
Thanks again

Phew. It worked perfectly on the MBP. I had tried first on the iMac but nothing happened. Strange that the 1.3 xmos update worked on the iMac but not on the MBP. And the reverse for the mcu update. iMac is running High Sierra. Go figure.
Thanks a ton. I am now a happy camper.

Thanks for the updates!

Just a follow up if all your issue including the MCU firmware upgrading got resolved?

BTW, note to upgrade both the v1.2 XMOS & MCU firmware first then upgrade to v1.3.

Good day!

1 Like

OK. Went back to v1.0. Did the xmos v1.2 then mcu .
Then again xmos v1.3.

Hi folks. Excuse me if my question is out of date. I have Khadas Tone2, version 1.2, serial number 14A…
Is there any reason I should use the special procedure of updating firmware from version 1.1 to 1.2 ?
In any case, from now on, how can update the firmware to version 1.3 ?

Hi LorenzoMA,

You can directly upgrade from V1.2 to V1.4 version firmware.
In fact, yours is Tone2 Pro, not Tone2, please pay attention when downloading firmware and updating, do not update wrongly, otherwise the device may not be recognized.
more info about the v1.4 firmware, please check this, have fun.

1 Like

Hi @kenny , I just got a Tone2 pro _fw v1.0 (serial _11A100C1)
How can I get this MCU hardware ST-Link v2 tool ? (I lived in Taiwan)(I updated it into v1.41 firmware without MCU)
Please let me know what process should I apply for and appreciate if any link provided to me
Thank you~~~~

Hi wavewave,

  • How to get ST-Link v2 tool?
    you can get it from some Online shopping platform, such as amazon, shopee.

  • How to upgrade Tone2 Pro’s mcu please check here

Thanks , will give it a try