Tone board not recoginized

Got my second tone board, plug it in, but nothing. No sound, nothing in device manager.

Did a web search, but did not find anything helpful.

Using Windows Home edition.

My older tone board works on all my PCs, this new one works on none of them.

I thought it used a generic Win driver.

Connecting directly to MoBo USB

Ideas on how to solve this?

Hello, Please review this guide and see if it addresses the problem.

Installed the driver, restarted PC, still nothing. Nothing in Device Manager, no Tone Board to choose for output device.

Did not install the DFU tool, as I don’t need, nor want, the Khadas Audio Dashboard.

Any further ideas?

Thanks for the help

May have more to do with firmware on the TB1 than the driver. I do not know if you can determine firmware without the DFU tool.
However, I would think it should work out of the box.
Have you tried a different cable? What about a different host device?
Any LED observed?
Do you have a source with SPDIF output? Could use that to check TB1 for basic function.

1 Like

Thank you!

It is the cable, the cable that shipped with the Tone Board.
Swapped it out with the cable that shipped with the first, one, and all is good.

Now to hunt up a replacement cable.

Even with the defective cable, the LED light was on, which fooled me.
Thanks for your time!

Your welcome. Very glad to learn that your new TB1 is working.

Sorry for the trouble and inconvenience :slight_smile:

Can you help to take a photo of the USBC cable that packaged in the box? Just wanna double check why the issue still there.


Purchased a new generic cable, and Tone Board works now.

1 Like