Tone Board error with Thesycon 4.11 drivers


#1

Dear Khadas staff and community,

I have recently bought the TB. An excellent DAC that I was loving since the first second for the clean sound and the details. However, I have some issues…

I use Tidal for streaming, everything was working perfectly when I connected it to my PC. After a few minutes of listening, I had to change the USB port on my PC as the sound was completely distorted. I solved by simply changing the USB port (from a USB c to a standard USB3.1). Not bad yet strange…

However, my favourite tool to listen to my ripped CDs is JPlay7, which was not recognizing the TB at all.

I have first installed the 2.24 drivers (Thesycon-Stereo-USB-Audio-Driver-V224.rar). JPlay recognised the TB but only as a Wasapi device. Nonetheless, I used it for couple of hours without any noticeable issue.

Since JPlay sounds better if used as KernelStreaming I installed the 4.11 version of the drivers ([Only for some OS Upgrade XMOS]-XMOS-TUSBAudio-EVAL-V4.11.0-Setup). I was really happy to notice that JPlay recognised it as a KernelStremaing and it was playing all the music correctly. The only thing I noticed at the beginning was the change of the name (from xCORE-something to XMOS XS1-U8-*). Nonetheless, after a while, I started hearing a 500Hz tone during music play.

It is a pure tone, which lasts about 1 second, it does not interrupt the reproduction (which continues properly when the tone ends).

I have tried playing with all the BufferSettings (from minimum latency to extra safe, no tries with ASIO buffer size as KS is inside ASIO my geuss it is not a problem of buffers). It does not seem to depend on the load, stress, number of programs I am using on my PC. Sometimes I didn’t hear this tone for hours, sometimes I hear it every 1/2 minutes (which is really bad as when you are ‘in the sound’).

I have experienced this tone with Tidal, foobar, JPlay. I have tested the TB on two PCs, one windows 10 and one dedicated Win2016 server (only used as a music server) that only JPlay installed. Same issue.

Then I have updated the firmware to the revision v6.F2. Nothing changed, exactly the same problem.

Any idea on how to solve this issue? Is it a problem with my TB? A problem of the drivers? Do you have any beta versions I could try? Anything that can help me enjoying 100% the TB is very welcome…

Many thanks in advance…


#2

small update: the 500HZ tone is also audible when no music is played, e.g., also when doing a skype call.


#3

I have the same problem. I couldn’ detect where tone is coming from.


#4

Both of you installed the 4.11 version of the drivers ([Only for some OS Upgrade XMOS]-XMOS-TUSBAudio-EVAL-V4.11.0-Setup),right?
Cannot use this driver enjoying music,you can switch the driver to V224 and try again.


#5

Dear Ben,

thanks for answering.

I rolled back drivers to V2.24 and, indeed, no tone is heard.

Nonetheless, two issues remain:
1- I cannot use JPlay to its maximum performance as I cannot access TB via the Kernel Streaming interface

2- with V2.24 the quality of the sound is worse than with v4.11, the sound is more alive and sparkling with the last driver. As you know, we all grasp for the best sound (buying TB is one affordable way to reach an excellent results).

Then, the question is: are you investigating the reason for that issue? Does anyone else in the community investigated the reason for that spurious sound?

Are there intermediate drivers we can try? Are there planned driver updates from Thesycon?

Many thanks in advance.


#6

It may take some time to deal with the problem,We have been testing these issues previously on volumio systems.

As far as I know, I have not seen relevant posts.

There are currently no plans to customize Thesycon drivers, and there are sure to be custom driver releases in the future.


#7

Ben,

many thanks for your availability and the quick reply.

I’m looking forward to see updates (to drivers or firmware) to further improve your TB (which is already an excellent DAC) and remove this noisy tone and use the TB to its best.

BTW, did you sort out this issue on Volumio?


Firmware upgrade. what file to use?
#8

VIM+Volumio+Tone,It’s working fine so far.


#9

Having the same 1 second tone after a while in foobar, youtube, games, … seems there is something with the drivers. Are we gonna get some updates regarding that?

THank you

Tade


#10

Simply put, if you are using a windows-based system and you installed the Thesycon drivers v4.11, roll back to v2.24. It’s not the same level of details (4.11 slightly better) and you will not access TB in KS more (if you use JPlay), but you will not hear this beep.

Didn’t try with other OSes (I will test Audiophile Linux soon). However, they look too driver-specific to appear elsewhere.

Let’s hope they will sort our the issue, also because I planned to buy another Thesycon-based DAC and I would like to use the last drivers…


#11

I think this is somehow connected with the EVAL license stated at the end, however there should be drivers that work without those tone, even if there are some to pay for! If this is an error, even better, it means there will be another drivers with this excelent quality!


#12

@Ben007, do you think that the sound is generated by the EVAL version? Or it may depend on the way you programmed the XMOS interface?
The fact the the tone was generated in a completely random way is not in conflict with the former hypothesis.

In that case, it could be worth trying with other customized 4.11 Thesycon drivers by other DAC producers that use the same XMOS inferface may work? (I found a few for other XMOS XU208 devices not sure about 128-QF as other specs are not as precise as yours). Or do you suggest us to refrain from doing that as it wouldn’t work?

Thanks.


#13

Great question!
As I know there were already V226 drivers available for some time.

Following!


#14

I also found the driver v2.26 is in another folder in the Khadas TB repository (just cheked not there any longer).
I have found several v3.* and v4.11 drivers customized for other XMOS products on the web. But before investing time and risking the stability of my PC (you know Windows may react strangely when you play too much with drivers) I would like to have a feedback from Khadas people
(I know, we abuse their availability).

Thanks


#15

Sure, please use V224 XMOS driver.


#16

Can we expect any new version of drivers? :wink:


#17

[quote=“Urajmal, post:16, topic:3307, full:true”]
Can we expect any new version of drivers?
[/quote]。
Windows10 and new MAC didn’t need install drivers V224 is stable.


#18

This is true, you don’t need drivers. However, with more recent drivers the sound is better and even more refined. And also installing Thesycon drivers V2.24 the TB cannot be used via Kernel Streaming, which is the best way to use JPlay. And this is a pity, as you DAC is wonderful.

But I understand this is not your priority…

So, thanks for now, we look forward to see custom drivers.


#19

I will be still waiting for the 4.xx version of drivers, this is so bad, that they don’t work as it should!

Will follow :wink:


#20

There are new drivers available as of 19th of January. Who is willing to test it with me? :slight_smile:

https://www.xmos.com/developer/published/usb-audio-class-20-evaluation-driver-windows