Tone 2 Pro only plays Tidal MQA at 44.1kHz

My Tone 2 Pro just arrived. I have the Khadas USB driver installed, disconnected and reconnected the device as per the instructions. I even tried it on another PC without the driver, same issue.

However, whenever I play MQA tracks on Tidal (exclusive mode), the LED indicator on the Tone 2 Pro shows a single bar of blue. The manual says this means it’s playing MQA but only at 44.1/48kHz instead of 88.2/96kHz or higher. The USB driver panel confirms this, saying that the device is only playing at 44.1kHz.

This happens regardless of whether MQA passthrough is enabled. Oddly enough, the Tone 2 plays my local Hi-res FLAC just fine. The LED lights up to 2 bars of yellow (88.2/96kHz PCM). The USB driver also says 96kHz correctly.

What’s going on here?

1 Like

I don’t have connected my Tone2 Pro to a PC, but through a Raspberry Pi and have the same exact issue, It only lights as PCM 44./48K. I’ve tried MQA files with different resolutions,

Furthermore, it is not paying Native DSD. It converts to PCM. On Roon doesn’t even give you the option to play Native DSD, as it does with all my other DACs that play Native DSD.

I hope all these issue it’s because it’s new and they’re just overwhelmed trying to deliver all those preorders. Staying positive. :slight_smile:

BTW - does this gets directly to their tech support?

Edit: Jan 27th

I plugged the T2P to my Mac to get the full path in Roon and it seems that is Full decoding MQA. The knob lights work as explained in the manual for MQA this way, but not using Raspberry Pi as bridge.

DSD files are not playing native. Roon doesn’t display the options with my other DACs.

Hello, I don’t have my T2P yet. Khadas Team members are integral to this forum. You can use @ in front of their names to call their attention to a post. For instance, @tsangyoujun .

3 Likes

Ty for the reply. I got this issue while connecting my T2P directly to both my PC and laptop. Unfortunately, I don’t have Roon to try on.

Hi, I have the same issue, did you find a solution please? thanks

Unfortunately, not yet. There are newer posts regarding the same issue from other users as well. We just have to hope the Khadas team will address this.

1 Like

@Eric68 please help…

Hello.
We test MQA files and DSD files with foolbar2000 1.6.2 on window 10, it is OK. And according to your issues,you can send your files to me, including MQA files and DSD files,I will inform to you the results when I finish to test with your files.

1 Like

Thanks for the reply. Unfortunately since the files are streamed from Tidal on PC, I don’t have the MQA files myself, so I’m not sure how I can send the files over to you. If you happen to know how, I’m all ears.

Hi
You can also download foolbar2000 1.6.2,and use this platform same with me to test your files.And then tell me the results.I will reply you as soon as possible.

Alright, I downloaded an MQA track and tested it with Foobar2000 ASIO out, and that seems to do the trick. The LED ring now properly shows the right sampling rate. (However, the driver dashboard still displays 44.1kHz, whatever.)

Streaming Tidal MQA, however, is still stuck at 44.1kHz. This seems like a Tidal issue, although I don’t have the same issue with other MQA devices on Tidal.

Yes,the foolbar still have the bug that it cannot display the right sample rate when play the MQA files.

Hi Bhu_Sor,

I don’t have this problem at all, mine is showing Magenta if I let Tidal do the first unfold, and Green or Blue if I set Passthrough MQA on, meaning the Tone2 Pro does decoding+rendring. And the ring is different for each kind of sample rate.

Regarding the Audio Dashboard, it shows 44.1 or 48 if I set Passthrough MQA on, because it’s the samplerate of the file as it’s sent.
If I set Passthrough MQA off, Tidal app does decoding, and sent at twice the sample rate of the file, so 88.2 or 96, and the Audio Dashboard shows it perfectly.

More details :
if you set Tidal app on non-“exclusive mode”, it’s act like a non MQA DAC and the Audio Dashboard will show the sample rate you set on the Playback Device menu in Windows, up to 384kHz (I was not able to set higher on Windows). Led will be yellow.

if you set Tidal app on “exclusive-mode”, the app takes directly control of the Tone2 Pro and you have two options :

  • no passthrough : Tidal app does the first unfold (decoding) so a Master song will go up to 88.2 or 96 kHz, and the Audio Dashboard will show these numbers. Then the Tone2 Pro does the following unfolds (if any) and led location on the Tone2 Pro will show you the sample rate. The led color will be magenta.
  • passthrough on : Tidal app send the file without doing anything on it, so it’s 44.1 or 48, and Audio Dashboard confirm these numbers. The Tone2 Pro then does all unfolds (only decoding if the MQA file is up to 88.2 or 96, or decoding+rendering if the file is more than that. The led location will show you the sample rate, and the color will be Green or Blue, depending on MQA or MQA Studio.
1 Like

You might be interesting in the video tutorial below shot by @tsangyoujun recently:

2 Likes

Thanks, great idea to make Youtube tutorial like that.
Just one small thing, regarding DSD, it’s not exactly 256 or 512 more resolution but more 256 or 512 more changes, it’s the 1bit change frequency, while PCM has a full 16 or 24 bits change each time.
It’s like having big samples but less times in PCM, and having a continuous flow in DSD that change by only 1bit each time.

Any idea, how can I enable Native DSD in Roon?
image

Hi,

this is what I have in Roon, and the Tone2 Pro light in white on DSD :

If you don’t have Native available, it’s certainly because you have enabled the WASAPI Tone2 Pro, not the ASIO one in the Roon device list.
Are you sure to have enabled the Tone2 Pro ASIO

3 Likes

How do I enable ASIO on the Tone 2 Pro? I am not connecting the Tone 2 Pro to a PC. I have it connected to Raspberry Pi 3.

Hi @TrueAudio
I’m not sure because of your setup, but in Roon core on a Windows PC, in the list of audio device, the Tone2 Pro, like all device capable of using ASIO, is showing twice, one with the Windows driver, and one with ASIO (for me, the ASIO version of each soudcard/DAC are in the bottom of the list).
You just have to disable the other version, and enable the ASIO one

Check if you see that

I figure it out. ASIO only works on Window or Mac. ALSA is is on Lnux and I jave Roon core on a NUC with ROCK, which is Linux. It’s connected via network to an Raspberry Pi running dietPi, which is also based on Linux.

I’ve seen others running very similar setting as mine Roon ROCK > Raspberry Pi > Tone 2 Pro and they show Native DSD setting on Roon setting. I’ll ask on Roon Facebook group, maybe other already figure it out.

Thanks!