Tone 2 Pro not booting with Windows after v1.30

I didn’t have this issue with v1.0. It was fine. It started with v1.3.

I flashed XMOS v1.2, new MCU and then XMOS v1.3 and I think everything went well. Now I can use the preamplifier mode, so the update was a success.

When I turn on my computer, Tone 2 Pro lights up but it doesn’t appear in device manager and there is no sound. I need to unplug and plug Tone 2 again in order to use it, with every boot.

I tried reinstalling the driver, different USB ports and also tried it with different computers. The issue persists.

Hi @ArasU,
Are you able to update us the Serial Number to us?

And please help to take a photo to check if the Ring RGB LED is light on. If the RGB Ring LED is not light on, you might need to follow the guidance to upgrade the MCU firmware again.

BTW, just ensure the USB-C port you pluged is the one with USB labelled :wink:


1 Like

I did the whole MCU update process again and I think it worked. I rebooted my PC a few times and it looks okay. Thank you.

I’m not an expert on microcontrollers but I think the problem was my power amplifier. This time I did remove my RCA cables before updating. This was the only difference. So I’m thinking, maybe my power amp’s ground interfered with ST-Link’s. This was the only explanation I could come up with. It works perfectly now. That’s all that matters anyway. :sweat_smile:

1 Like

Thanks for the update and good to know the problem got resolved!

Have fun!

1 Like