Stuck on 8.1 green screen

I can never leave anything alone.

Tried to roll back from ATV tried a few older roms in the firmware downloads section put 7 on it and then went to 8 each had a different layout thought ide see the difference then once 8.1 booted the remote stopped working so i tried to put 9 on but now when it gets to the SD card like it did the previous 2 times the screen just goes green and wont do anything after that.

8.1 works if i use an air mouse keyboard

How do i get out of this?

I found some other users with similar problems but not with the edge they had the same problems but with the VIM2

We don’t do any maintenance on the 8.1 firmware, so we will remove the 8.1 firmware.


I just wanted to try it, its different, icons along the side search bar across the top

Is there a force flash method?

Maybe i need ot try Krescue? will it work for edge board?

probably it will be easier for you to wait for Krescue and ask Hyphop to create an Android 8.1 image, why do you want Android 8.1, specify?
There is also information that Android 10 for Rockchip will be released soon, maybe you better get rid of the thought of Android 8.1?


My thought was to try each of the past edge android version and do a benchmark then try each one and see which was fastest for the game i play

I tried the mo123 and got less of a score then my CSA96 box so i thought maybe it was faster because CSA96 uses 7.1 android?

I know benchmark doesnt tell much but its fun to tinker thats why i got SBC to tinker around with and try Roms but i didnt get very far and already messed it up and now im trying to figure out how to fix it, im new so im needing help tell i figure it out

I dont really want 8.1 i just want the fastest and most stable is thats possible?

wait, you do not quite understand correctly, in addition to the test, did you try to start the game and play?
And yet it seems to me that mo123 relies on multimedia features


Since edge is older board and ther eare many android versions i thought i would try all the past roms and then do benchmark and see which was fastest

Also i wanted to see the older past roms and see apps and looks of rom just for fun and to tinker with roms on edge board

did you have problems while playing games on mo123 firmware?

a few little things, not real important

you tried to contact him, I think he is open to communication

Maybe start by clearing eMMC. Otherwise, MASKROM should allow flashing of a different firmware.
Android 8, 8.1 was a dud on most boxes according to opinions seen across the web. Abandoned for cause.

IM not sure how to clear the eMMC?

Does the khadas boards act like other android boards? holding reset while plugging in the power?

Does the khadas boards have a recovery screen like the other boards with the little green android robot?

I tried to boot to that but im not sure what the processes is with the 3 buttons

So far the android 8 is booting up and its working its just stuck and i cant reflash it the green screen is the screen that usually shows the bar at the bottom as it reflashes

Not quite sure, if that little green guy, comes to say good bye if he is being wiped out from the eMMC :upside_down_face:

Well im not sure what its called it slike a list of things like a bios has the wipe cache and wipe memory and other things

Do these boards boot to that menu?

I could probobly wipe it that way if so, I dont hav ethe 3 buttons memorized yet what they all do

you can refer to that from the Edge beginner guide,
Erasing eMMC with buttons on Edge does not appear there though, :confused:

I linked to the instructions to clear eMMC in my previous post. One of those methods should work.

1 Like

yes, you need to forget about android 8, since it already has no support, why don’t you want?

WHy dont i want?

I already explained why i installed it, im sorry i did :crazy_face:

Wait, im sorry i installed it :roll_eyes:

I tried it when it came out. No harm, no foul in trying it. As a former compulsive Linux distro hopper, I understand. :smile: