Strange behavior of cooling fan using Android 9

Dear Khadas support,

I am experiencing a strange behaviour using an Edge-V and the cooling fan under Android 9.

  • Setting the fan to low, medium and high speed works.
  • If I enable the “Auto”-mode the fan neither turns on nor off (independent on the temperature).
  • If I disable the fan completely it stays on.
  • Using ‘setprop level 0’ only has an effect if I open the fan menu, then the fan stops. Same with turning it on with that command, I always have to open the fan menu to see an effect.

What would I need to do to use the automatic mode?
Which command would I need to run after ‘setprop level’ to make the fan react to that command?

Thanks for any help.

Best regards,

@Raimo What is your firmware version?

@goenjoy I am working with Edge_Pie_V190912.




I didn’t find this problem. How did you close it?

echo 1 > /sys/class/hwmon/hwmon1/mode
setprop 1

Dear goenjoy,

Thanks for your answer.
I got the automatic mode working with

echo 1 > /sys/class/hwmon/hwmon1/mode
echo 1 > /sys/class/hwmon/hwmon1/enable

Somehow switching it on the the Android menu had no effect.

Best regards,

If you execute the command and the menu switch, you will confuse the original logic.

Hi @goenjoy

Some other user also has a problem with the ‘low’ fan menu
‘same with the fan, it will be set to low but not running till i turn it to auto then go back to low’

I checked and is the same latest code I used.

Can you check if there is perhaps a bug where it gets stuck or something?


I didn’t test the problem you reported. But sometimes the fan doesn’t turn. It needs to wait a while.