[ROM] SC VIM1 Pie “Normal” Debug/User Builds v2 20200210

i use new burning tools,result is the same…Older img files with android 7.1.2 works without problem

Maybe erase eMMC prior to flashing. What version of Windows are you using?

1 Like

ye i totally forgot that, thks for the reminder @RDFTKV


I getr new power supply for khadas and result is the same…Do you mean erase all in USB burning tool when i flash?


hi, you can use Krescue

Hello @gotovanko1 you need to enable “erase all” in the Burning tool, otherwise errors shall arise…

how are things with other OS? you can check?

1 Like

Android 7.1.2 working good…other roms just freezing in circle animation


Is this even after “erase all” has been applied ?

very strange, maybe Superceleron can help you

its going to be hard i need to see in real time the log its coming from the device.
Something is going wrong in the boot process to make the device hard locks.
Anyway is very very strange, what revision of the board do you have?

I understand thanks guys,so far i don’t think to play anymore with this demo board, i buy spare parts for new one, i guess on new chip set update to new android will be much better. So far even with old android ,its enough to put auto frame rate and all of my main programs that i use to work. I get board when it was new model on market i guess it version 1.0 ,but i don’t think to reassemble again,because i loose some bolts and was hard to find it

1 Like

buddy, do not rush to draw conclusions, for now you can set AFRd for automatic frame change, you need to put the assembly with ROOT access, moreover, here are ready to help you

you can see this information on the board itself

you are hinting at vim3?

If I installed the user build ( v2 with no root ) on a TVBox by accident (I misunderstood that this ROM was only for the VIM1) and I cannot press the reset button to enter recovery but I can enter recovery using adb, how can I install a stock ROM on my TVBox in order to erase this ROM?

I tried installing the stock ROM using the Update app and the recovery menu with no success because “ro.product.device” is null and I can’t change the signed ROM update-script to not perform this check.
I also tried installing TWRP using fastboot but none of my computers seem to detect the TVBox when in bootloader mode.
Also, the PC can’t detect it (while in recovery mode) using USB Burning Tool of Amlogic in order to flash a new ROM and I can’t flash a new ROM with an SDCard as that seems to not work as well.

After trying all of that, what are my options in order to reinstall the stock ROM on my TVBox?

Thanks in advance.

Hello, You may need to find out how to get your box in MASKROM mode, maybe then the USB Burning Tool will see it. You may find more help for your particular device over at Freaktab.com
Others here may be more helpful than I.
Hope you recover it.


After some tries, I found the following issues:
1 - I have to disable hardware acceleration in VLC in order to play videos;
2 - Android security patch level is at August 5, 2018; is there a way to update it?
3 - I can’t find a way to show other apps and to split screen;
4 - after Power Off the system starts again;
5 - scrcpy tool often terminates abruptly (with Nougat this behaviour was rare).

Furthermore I’d like to customize apps; can I ask you to install launcher and other apps (as many as possible) as users apps instead of system apps, so they can be uninstalled?
Otherwise I need a way to access system from outside; does anybody knows if there is a SD-USB tool (like TWRP or even within Linux) that I can use to edit system partition, without the need of rooting?

In the end, is there the possibility to get (or build with detailed how-to) a vanilla LineageOS for VIM1?


This board is fantastic and superceleron work is super!

1º yeah i know, it’s a known bug, for now still no fix for it.
2º ignore it, its updated don’t worry just forgot to update the text.
3º split screen is disabled at the moment.
4º ye my fault i forgot to do some changes in uboot.
5º ye i know same thing as the 1º one, its the same bug.

i cant do that, since many of the apps are system apps and not user apps.
Right now i set as user apps Netflix, Total commander and Vlc.
Without root? hmm nothing i know, i will try to add in the next build TWRP but no promises since i do not have much time to work on this devices.
On the LineageOS for vim1, is not hard, i think i saw some how-to’s online, cant remember where.

Thank you for the prompt and exhaustive reply.

I thought it was possible to run Linux from SD, mount emmc Android partitions in some way and perform the needed changes. Is it not possible due to encrypted data or Android partitions filesystem is not natively supported by Linux?

Regarding LineageOS, I’ve seen it is named in the discussion “Android Q 10 for Amlogic S905x.” on FreakTab forum by sagert user. Probably it is an early stage ROM, not fully compatible with VIM1 and furthermore ROM links are not available. I should ask there.