RMA Procedure Please?

My khadas vim3 suddenly died.
The led does not lit.
Tried 2 different power supply.
Please advice RMA procedure.
My order number is #12259
Thank you

What happened ?,How did it die,
Are you not getting any screen output, please enumerate the situation,
If you try to get replacement it will take a long time for the shipping to happen, try to fix the issue and see if it somehow works, in the last case scenario try to ship it back,

There has been an awful lot of hardware failures nowadays, but some are really simple reasons, like a missing resistor or improper solder joint, don’t know why…

change the power cable

tried another cable, no joy

t was working well till now.

Suddenly it does not power up.

The LED that usually becomes lit upon power now does not light up.

Tried using 2 power supplies, still cannot light up.

Something wrong on the power side.

Are there any power fuses?

maybe there is simply no power from the device to which vim is connected, check to connect to other places

tried another confirmed working power supply
metered output with multimeter, output is okay 12VDC

other than the led not glowing are you getting any video output or anything else ?

no signs of life …

Press F to pay respects, :pensive:

I guess sending it to khadas for repair inspection is the only choice left.
May be @Kingsley could help you with the shipping process

if you have a tester, then you need to ring the dots, see where there is no signal, maybe the power connector is loose

why is the fan in reverse?, the motor hub should be facing up you have to flip it,
Does the Fan spin at all ?

Btw why are those jumper wires connected ?

1 Like

Jumpers were to test IO, now no connection, not shorted.
Noted fan is upside down.
unit was running for few months in this configuration

suddenly died.

if possible, Could you show a video of it being powered up, I would like to see what happens,
make sure the fan is facing upwards, what was the ROM installed on the eMMC, maybe you might have accidentally erased the eMMC, could you try connecting it to a computer and see if its being recognized and whether you can reflash the eMMC ?

Will try to video but dont it it meaningful, it just show a board with no response.
Note that I was being tested by running programs when it died.
There was no develoment work being done, so could not have wipe out the emmc accidently.
During development would have been very careful with rm and dd.
System is running ubuntu , version shld be 18.04

Can try to connect to PC but shld be not meaningful unless the LED is lit and blinking.

The unit is not with me presently, we operate them remotedly usually.

This unit running for some time already.

just try connecting it to a pc and burn a android image just to verify if it works otherwise its poof :slightly_frowning_face:.

Is the board always open? could there be a short circuit, something accidentally hit and break through a board for example?
although there probably would have been a burning smell and you might have noticed, inspect the board visually, maybe something happened in your absence

yes @RichardG try to inspect the board for any odd changes maybe a delicate resistor could have knocked of without notice

yes, maybe it’s a diode in the power circuit conditionally