Rii Mini i8+ (BT version) not working in Android 6.0.1

@peerobo Thank you but link does not work (file not found)

It does not work. Only pairing does work :slight_smile:

@Terry Thank you, i put the files in dropbox: https://www.dropbox.com/sh/f99dnal6y1mf31c/AAB6nuhd7poe6XhjQC4kH_BZa?dl=0

I’m sorry, please try again with this link.

Still not working with the VIM_Nougat_V170901… What information do you need to fix this?


I have reduced the logcat to the relevant parts. It now shows only entries from clicking on “Add accessories” to the failed pairing. I removed the part before since it is not relevant.
Link to the file: https://www.dropbox.com/s/5m1kkcbglyvi1f9/logcat_shortened.txt?dl=1

What I did was the following:
Go to Settings -> Add accessory -> Then enabled pairing on the Rii i8+ and it showed up in the device list as “Bluetooth 3.0 Macro Keyboard”.
I clicked on it, then the text went from “Pairing…” to “Connecting…” and then “Couldn’t pair”.
This can also be seen in the logcat file.

How can this be fixed?


I am sorry to reply for you so late.
This is the National Day Holidays in China. I am not at office.
I will pay attention to it after the holiday.

Hey terry,

thanks for your answer! No problem, I will wait until after your holidays.
When you are back at work, just tell me what information is needed for figuring out this issue :slightly_smiling_face: I will try to provide it to you.

1 Like

Ok, thanks for your understanding.

Hi, Neeco
I tried to search for Rii Mini i8+ on linux source code. But I couldn’t find it on HID BT driver.
Can you provide the Vendor ID and Product ID for me ?

Hey terry,

sure, when I connect the Rii mini i8+ to my Macbook, I can see the following information in the system report:


If I can enter them somewhere, just tell me what to do :slightly_smiling_face:

Thanks Neeco.
I found the HID BT driver.

#define USB_VENDOR_ID_APPLE     0x05ac


I will provide the boot image for you. Can you flash the boot.img? what’s the version of your system?

Interesting that it says “Apple Alu Wireless”, since the device is not Apple.
Maybe they use similar hardware?

If you could link me to a guide how to flash the boot.img, that would be awesome. Never done this before.
I have only flashed the update.img files with the operating systems.
Version does not matter, I can completely reflash Android. Most preferably the latest with root (Vim_Nougat_Root_170612) from your docs page http://docs.khadas.com/basics/FirmwareResources/

Thanks for your help!

I built a test ROM for you.
You can update your system and have a try.
Also please give me the feedback about it.


Works like a charm, thanks terry!

When you have time, maybe you can explain what you did and how I can also do it for new Android versions?

You only need to modify the file common/arch/arm64/configs/kvim_defconfig and enable config CONFIG_HID_APPLE

diff --git a/arch/arm64/configs/kvim_defconfig b/arch/arm64/configs/kvim_defconfig
index 12409aa..269ac59 100644
--- a/arch/arm64/configs/kvim_defconfig
+++ b/arch/arm64/configs/kvim_defconfig
@@ -2830,7 +2830,7 @@ CONFIG_HID_GENERIC=y
 # CONFIG_HID_A4TECH is not set
 # CONFIG_HID_ACRUX is not set
-# CONFIG_HID_APPLE is not set
 # CONFIG_HID_APPLEIR is not set
 # CONFIG_HID_AUREAL is not set
 # CONFIG_HID_BELKIN is not set


I am having the same issue at 7.1.2 with BT Keyboard Rii Mini I8+. Is there anyway to get that custom image again please …

I’m having this same issue with the Buzz TV. Would this solution work for me as well? If so can you give directions as I’m a bit loss.

@cayman2018 You can flash your VIM with VIM_Nougat_V180210
Have a try. Thanks.

Thanks. Any instructions on how to do that? Does it matter what time of box I have as long as it’s running the Android OS?

It doesn’t matter.
You can refer to this

Terry I have a Tanix TX92 box and was wondering if I could somehow log into the box and modify this myself? Without having to load a ROM?

Cayman, I have the same issue with BuzzTV XPL 3000 and Rii BT remote. Im a novice, can you help me how to fix it?