Rii Mini i8+ (BT version) not working in Android 6.0.1


#1

Hi,

I bought the Rii Mini i8+ touchpad+keyboard (I bought the Bluetooth version!, not the 2.4GHz version). It works perfectly on my smartphone (Android 6.0). But when I pair it to the Vim, both the touchpad and the keyboard do not work. Why is this?

Android version is the one the Vim came with (6.0.1, Kernel-Version: 3.14.29, Build-Number: Vim_Marshmallow_20170303).

Is there any fix for it?


#2

I have the 2.4ghz version with dongle and LibreELEC on eMMC, it runs fine though.


#3

Yeah but I don’t get why the BT version of this keyboard is working on other Android devices like my smartphone. I will try the Nougat ROM for the VIM and see how it goes…


#4

I wonder what they did to the bluetooth stack in the Android ROMs. On Nougat it is still NOT working. On the other side, on my smartphone it works like a charm (as I said it is Android as well), and in windows it also works smoothly. Just not on this damn device.

EDIT: I forgot, on Nougat it doesn’t even pair anymore. On Marshmallow at least that worked

EDIT2: Apple Wireless Keyboard is also pairing under Marshmallow_20170303 but also typing does not work. Same as with the Rii mini i8+ BT. But audio is working via a BT receiver. So I guess it does not have something to do with the Bluetooth Stack but rather with the input settings. Can anybody help?


#5

Could you please try this LibreELEC rom to see if vim has bluetooth hardware failure?
LibreELEC BALBES150

Extract [.gz] then burn [.img] to usb/sdcard with Win32DiskImager:
Win32DiskImager
Delete [dtb.img] in usb/sdcard.

Activate boot from sdcard/usb: Boot into Android, plug-in sdcard/usb, enter Settings -> System -> About -> Update -> Select file aml_update.zip in sdcard/usb -> Update.

Boot into LibreELEC, then try to pair the keyboard to see if it works.


#6

Can you provider the printing log for me when the Rii Mini i8+ is working on Marshmallow?
Thanks.

$ adb shell logcat > android.txt
$ adb shell dmesg > kernel.txt

#7

@peerobo Thank you but link does not work (file not found)

It does not work. Only pairing does work :slight_smile:

@terry Thank you, i put the files in dropbox: https://www.dropbox.com/sh/f99dnal6y1mf31c/AAB6nuhd7poe6XhjQC4kH_BZa?dl=0


How to connect I2S DAC
#8

I’m sorry, please try again with this link.


#9

Still not working with the VIM_Nougat_V170901… What information do you need to fix this?

EDIT:

I have reduced the logcat to the relevant parts. It now shows only entries from clicking on “Add accessories” to the failed pairing. I removed the part before since it is not relevant.
Link to the file: https://www.dropbox.com/s/5m1kkcbglyvi1f9/logcat_shortened.txt?dl=1

What I did was the following:
Go to Settings -> Add accessory -> Then enabled pairing on the Rii i8+ and it showed up in the device list as “Bluetooth 3.0 Macro Keyboard”.
I clicked on it, then the text went from “Pairing…” to “Connecting…” and then “Couldn’t pair”.
This can also be seen in the logcat file.

How can this be fixed?


#10

Hi,Neeco:
I am sorry to reply for you so late.
This is the National Day Holidays in China. I am not at office.
I will pay attention to it after the holiday.


#11

Hey terry,

thanks for your answer! No problem, I will wait until after your holidays.
When you are back at work, just tell me what information is needed for figuring out this issue :slightly_smiling_face: I will try to provide it to you.


#12

Ok, thanks for your understanding.


#13

Hi, Neeco
I tried to search for Rii Mini i8+ on linux source code. But I couldn’t find it on HID BT driver.
Can you provide the Vendor ID and Product ID for me ?
Thanks.


#14

Hey terry,

sure, when I connect the Rii mini i8+ to my Macbook, I can see the following information in the system report:

rii_i8_information

If I can enter them somewhere, just tell me what to do :slightly_smiling_face:


#15

Thanks Neeco.
I found the HID BT driver.

#define USB_VENDOR_ID_APPLE     0x05ac
#define USB_DEVICE_ID_APPLE_ALU_WIRELESS_ANSI   0x022c


    { HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_ALU_WIRELESS_ANSI) },
    { HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_ALU_WIRELESS_ISO) },
    { HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_ALU_WIRELESS_JIS) },

I will provide the boot image for you. Can you flash the boot.img? what’s the version of your system?


#16

Interesting that it says “Apple Alu Wireless”, since the device is not Apple.
Maybe they use similar hardware?

If you could link me to a guide how to flash the boot.img, that would be awesome. Never done this before.
I have only flashed the update.img files with the operating systems.
Version does not matter, I can completely reflash Android. Most preferably the latest with root (Vim_Nougat_Root_170612) from your docs page http://docs.khadas.com/basics/FirmwareResources/

Thanks for your help!


#17

I built a test ROM for you.
You can update your system and have a try.
Also please give me the feedback about it.
Thanks.


#18

Works like a charm, thanks terry!

When you have time, maybe you can explain what you did and how I can also do it for new Android versions?


#19

You only need to modify the file common/arch/arm64/configs/kvim_defconfig and enable config CONFIG_HID_APPLE

diff --git a/arch/arm64/configs/kvim_defconfig b/arch/arm64/configs/kvim_defconfig
index 12409aa..269ac59 100644
--- a/arch/arm64/configs/kvim_defconfig
+++ b/arch/arm64/configs/kvim_defconfig
@@ -2830,7 +2830,7 @@ CONFIG_HID_GENERIC=y
 #
 # CONFIG_HID_A4TECH is not set
 # CONFIG_HID_ACRUX is not set
-# CONFIG_HID_APPLE is not set
+CONFIG_HID_APPLE=y
 # CONFIG_HID_APPLEIR is not set
 # CONFIG_HID_AUREAL is not set
 # CONFIG_HID_BELKIN is not set

#20

Hello,

I am having the same issue at 7.1.2 with BT Keyboard Rii Mini I8+. Is there anyway to get that custom image again please …