Overscan control


I received my Khadas VIM device, so far soo good, upgraded using the latest Ubuntu image. But I’m not able to configure the overscan values so it does not go outsie of the TV visible area. Is it possible to do this?

Thank you!

You can try this
Plug device into PC. Open for editing the file amlogics905x_init.sh. replace the # sign from lines 720 and 1080.

Worked well for me

Information supplied to me by balbes150

Hi Robert,

Many thanks for your reply, much appreciated!
Please note I’m new to the Khadas VIM, so I have a question.

When you say “plug your device on your PC”, do you mean plug the board using the USB-C cable supplied? If yes, will the device be recognised as a mass storage device? Please note I’m using the internal eMMC flash, with the latest Ubuntu image loaded, not an uSD card.



Sorry my assumption at the time was you were running sd and balbes version SD, had just done the alteration.
My TV has a VGA in, I got hold of a VGA to HDMI and that was my quick fix.
As this is early release, things will improve.

Hi, Jose:
Sorry for the late response.

Does your problem resolved? If not, would be better to feedback your issues like this(I’ll follow it up):

  • Tell us the ROM version you installed
  • Tell us the hardware date code, i.e. Vim V1.2 1610 4916
  • Describe all the procedures(step-by-step) you did with details
  • Provde neccesarry photos to help us better understand the issue you are facing
  • If you are a developer, post the full printing log
  • Others information you thought would be helpful for us
  • If you are facing many different problems, please create different topics one by one, we will also reply one by one.
  • If your problem has been fixed, please follow the Problem Solved Button to mark it as solved

You can edit the file ‘/etc/rc.local’

echo 0 > /sys/class/graphics/fb1/free_scale
echo 0 > /sys/class/graphics/fb0/blank
+   echo 28 16 1251 703 > /sys/class/graphics/fb0/window_axis
+   echo 0x10001 > /sys/class/graphics/fb0/free_scale

window_axis: left top right bottom

the display is 720p
left + right = 1279
top + bottom = 719

the display is 1080p
left + right = 1919
top + bottom = 1079


Sorry guys, I was on a business trip, only back to the VIM now.

This is the info:

ROM: Vim_Ubuntu-16.04_V170124.7z
Hardware code: VIM V1.2 1610 4916
Just flashed the ROM using the supplied USB-C cable, using the utility USB_Burning_Tool v_2.0.8.
Before I post all logs etc will try the suggestion of using sysfs to correct the problem.

Thank you!


Success! Thank you Terry for the instructions. The desktop now fits in the display visible area.

Are the sysfs entries specific for the fb driver of this chip or are they generic?



PS: When I expand the buttons I don’t see the “Problem solved one”…

Kindly have a try again, and thanks for your feedback. (I just didn’t enable Solved Button feature for Khadas VIM category yet.)

Still don’t see the Solved Button

Ha, it appeared the moment replied. But was not present in the previous posts.

I guess you forget click the show more button :slight_smile: