OpenElec & LiberElec WishList


#109

I tried more than 10 different videos (they are posted on the NAS within the local network), the latency is the same everywhere. What sources do you use ? What model BT use ? Give links to samples of videos, where there is a different lag.
Preferably, something other users have written works for them (standard and gap). It is likely that this is a problem specific headphone models\firmware.


#110

The problem is not in the video, if you look without headphones, the sound does not fall behind - the offset is 0 ms.
Headphone №1: Bluedio R+ (bt v4.0) - sound displacement is stable 125 ms.
Headphone №2: EDIFIER W855BT (bt v4.1) - sound lags in the range of 500 to 1300 ms.
When using a bluetooth adapter (orico bta-403 bt v4.0, orico bta-408 bt v4.0), the offset is 0 ms or very close to this value.
The problem is definitely related to bt v4.2 Khadas boards.

Forgot to mention. I play video from my home library on wi-fi.


#111

I have a problem with LE ver 8.0.2 (build may 5 2017)
My wireless network is connected, with an IP from dhcp but I cannot ssh to my vim, also my vim cannot connect the internet (browsing addon from reposity is not possible, err “could not connect to reposity”).
Please help me out.
Specs:


#112

Try to test connect via a wired network and check in this mode. I don’t have version 4.1, so I can’t check.

Configured and enabled SSH access ?


#113

Yes. I have already enable ssh via service tab.
Assigning IP to Vim is ok but no networking is available, no ssh/LAN, no internet. My other devices can connect to the internet via the same wireless networking. So I guess the problem is the LibreELEC/VIM.
Ubuntu cannot connect to the internet as well. I will try restoring to android to check the wireless. Last time I checked everything was fine with stock android :frowning:


#114

now checked connection with ssh when connected only to WiFi (5GHZ). Everything works and the root user is connecting without problems.

Try deleting the connection on the router , something it was re-created. Possible when installing to eMMC changed the MAC address and the binding have remained. You connect to VIM over SSH when run from external media ?


#115

I have LE on eMMC, Ubuntu on TF. None can connect to internet. At the moment I’m restoring to stock android to check if it can connect to internet.


#116

Try connecting to a wired network, includes VIM with a wired network, check the operation with a wired network. Then disconnect the wires from the connector of the network card and try to configure the WiFi (without turning off the power of VIM).


#117

Stock Android can connect to the internet fine via wireless network.
I don’t have any available wired network, so I cannot test your suggestion right now. Maybe I will do it later.
When I installed LE, I deleted dtb.img on TF card because system couldn’t boot. Without dtb.img I could boot into LE then I rebooted/installed into eMMC. Maybe the step deleting dtb.img was the cause???


#118
  1. What firmware (which Android) now you have in eMMC ?
  2. Try to run LE with external media and check how it will work WiFi.
  3. What image Armbian on the SD card and what dtb it use ?

Checked himself Armbian works fine with WiFi in both cases (manually copying the dtb and without this file).


#119

Thank you for your time.

  1. Stocked Android in eMMC: Vim_Marshmallow_20170303
  2. Run LE on ext media: build 05-05-2017
  • Default dtb.img: cannot boot
  • No dtb.img or dtb.img from Vim_LibreELEC_V170116.7z : boot ok
  • When boot successfully, connect to WIFI ok, could not ping to VIM, could not connect to reposity, could not ssh, same IP as android.
  1. Run Armbian on ext media: Armbian_5.27_S9xxx_Debian_jessie_3.14.29_xfce_20170501
  • With default boot (no dtb.img): graphics is mess up => I cannot do anything
  • Copy dtb3.14.29/kvim.dtb -> dtb.img: boot successfully, no graphics glitch
  • Connected to WIFI ok, but could not ping to VIM, cannot browse the internet, same IP as android.

#120

What model You have VIM (2\8) or VIM Pro (2\16) ?


#121

My model is VIM 2GB RAM / 8GB eMMC.


#122

I’m VIM Pro (2\16). Now I understand why we have different Wi-Fi access. I’ll try to put the option of fix for VIM , but I don’t have that model so I won’t be able to test it.


#123

If I can help you anything to make the fix, please tell me. Thanks for your precious time.


#124

If You have the opportunity, check the Wi-Fi in the previous images 20170418 and 20170323.


#125

No problem. I will try those when I have time.


#126

I found some clues. Today I hook up VIM at another place, connect to another WIFI and it worked fine. Here is my network map, all are wireless:
internet <-> router A (dhcp) <-> router B (dhcp) <-> router C (no dhcp, bridge to B)

  • When I connect to router C (dhcp via router B): only stock Android can connect to the internet, LibreELEC can not.
  • When I connect to router B: all can connect to the internet, both Android and LibreELEC.
  • IP on both B or C are the same which is offered by router B.

Both router B and router C are connectable and usable by other devices than VIM, such as ps3, smartphone, smarttv…


#127

You can check to reset all bindings to the MAC addresses of routers B and C and to perform the first start VIM with the launch of LE ? It’s also possible that LE\Ubuntu causes error too long chain to gain access or timeouts.


#128

@balbes150 what repo are you building from ? Thanks.