No sound through USB interface. Help is needed

Which system do you use? Android, Ubuntu, OOWOW or others?

**Android.**

Which version of system do you use? Khadas official images, self built images, or others?

**edge2-android-12-v230625.**

Please describe your issue below:

`**I use “HELIX HEC HD-AUDIO USB-INTERFACE” when connected via usb, there is no sound. When you connect a phone (samsung note 20 ultra) via OTG, there is sound. I also used the Mekotronics R58x (rk3588) prefix earlier through which everything worked.
I use khadas edge2 in my car instead of a head unit in conjunction with a 4k oled touchscreen.

The HD-AUDIO USB-INTERFACE extends HELIX devices with a High Resolution Audio USB input and converts a PC or smartphone into a HD-Audio player.
The direct digital signal transmission (without additional AD-DA conversion) from the music source to the DSP with up to 192 kHz / 32 Bit allows lossless audio processing and thus assures perfect sound quality.
**`

@magetra There are two USB ports on the board, have you tried both? If you have tried and there are still problems, please grab the logcat log and send it to me.

I tried different ports on khadas but no sound. When using the USB check application, khadas detects it as HD-AUDIO USB-INTERFACE. I saved the logs via android studio giraffe logcat.
For information: I have a touch monitor connected to khadas under thunderbold (type-c). When I was recording the logs, the monitor was physically turned off.

Cat Log

You can use WiFi adb to capture logs.

Hello, can you solve my problem? Have you looked at the log I have attached?

@magetra cannot looked at the log.

Sorry, I was away without internet. I will upload catlog to google cloud. If you can’t open or removed the catlog incorrectly, write to me so that I know. Thank you

CATLOG - https://drive.google.com/file/d/1psTtp-SPyr1Zz6mLEFp8utZZqGgDgb6N/view?usp=drive_link

@magetra cannot looked at the log.

I’m sorry, I made a mistake when I posted the catlog. I received an email that you tried to open the file but there was no permission. I changed the permissions for everyone.
please open it.