No HDMI signal detected form VIM3L

I just purchased a VIM3L and Tone board and am trying to set up a Volumio streamer. I’m following the advise on the Youtube video - ‘Installing Volumio for Khadas VIMs’.

I have used balenaEtcher to burn to an SD card.
I’ve powered up and the LED is flashing.
I’ve inserted USB flash drive with VIMx.Volumio.last.emmc.kresq
I’ve connected keyboard and HMDI cable.

I don’t have an HDMI computer monitor in the house, but I’ve tried 2 different TVs (both Sumsung) and they both say ‘No HDMI Signal’

Are they not compatible, or am I doing something wrong?

1 Like

Are you using a good power supply, say 10W

which resolutions supported ? FullHD ? 1920x1080x60 ?

Yes, I first used a standard usb plug adapter, but thought this may be a problem so I purchased the Khadas 24W power adapter.

VIM3 + krescue can work from common usb laptop/PC port - without problem

PS: if krescue successfully started ! led must stop blinking

Not sure, I tried various formats, but couldn’t actually see the resolution. I’ll have another look when I’m home later.

OK, led has not stopped blinking. Are you saying I should connect USB to laptop instead of using the flash drive?

Hello! I want to clarify, are you unable to log into Krescue or Volumio after installing with Krescue?

Here is your image from Krescue on SD, please check …

1. connect the VIM3L with the SD card containing krescue to your PC with a USB-C cable USB-3.0 port preferable

2. After the device finishes booting up, (blinking stops) The VIM3L should appear as a RNDIS device (ethernet adapter),
open a SSH session into the VIM3L
by finding the IP address it has

Alternatively you could just SSH into the VIM3L when connected to your network

3. Enter the required commands to install Volumino to the eMMC

I don’t know the exact commands to do it as i don’t have it, but hyphop instruct you ,
@hyphop could you follow up

this is not necessary, Krescue will already have all the images and tools for work. :slightly_smiling_face:

I am talking about SSH method, so you have to use Commands to install Volumino into the eMMC

this is also not particularly necessary, I can completely control with one vim, moreover, as you say, connect an Ethernet cable

SSH over the network ?

wait, why use two devices? just one vim is enough!

@Richard said he could not connect his VIM3L to a display and get the Video output of Krescue,
So @hyphop suggested to SSH into the VIM3L and execute the commands necessary for Volumino Installation

So I gave some instructions to ease his installation process :slight_smile: , that’s why I said,

well, at least that way he will be able to see his vim, and if there is no connection? but most likely he just could not log into Krescue correctly

I agree with you, but only after he makes sure that the connection between PC and vim is present on the network! :slightly_smiling_face:

1 Like

for ssh shell u can use just one command krescue

PS: read about access to krescue +

PSS: full automate method

generate auto installation sd with volumio (just install sd boot and wait installation finish)
curl -sfL | sh -s - -A VIM3L -m volumio.last >

PSSS: krescue have have wide range methods :wink:


Many thanks for the help earlier, I still have problems but have got a little further. Apologies if my questions are a bit basic, but I’m very new to this!

This is where I’m at now - The video output is not the problem, I can use my TV ok. I think I have a problem booting krescue.

I have inserted USB-C power cable while pressing the power button. I wait for led to blink before releasing power button. (white led repeats 2 quick blinks, red led comes on once soon after power up).
White led continues blinking - I’m not sure how long it’s meant to blink for, but I waited well over a minute. TV at this stage still says no HDMI signal.

The only time the led stopped blinking was when I accidentally pressed the reset button. Then I got an HDMI signal and saw the Khadas android home page. I could see the krescue drive, but not all the files on it.

To create the SD card I used balenaEtcher (on a MAC) and flashed the file that you mention above -

That’s as far as I got

That’s exactly what I thought. Okay, now try inserting SD, turn on vim in your power, and do nothing else.