MultiOS_3in1 (Android+Libreelec+Linux) install to eMMC


@balbes150: By the way: The reboot to “android” and “libreelec” from within ubuntu mate loaded from emmc were gone after I added a new user (also administrator rights) and deleted the standard user. How can I re-add the shutdown menu (or which commands/scripts are used to reboot to “android” or “libreelec”) for ubuntu?


In one of the topics on the forum was a description with pictures how to restore these menu items.


Hi @balbes150
Maybe I’m out of topic, I wonder if this MultiOS_3in1 works only for VIM2 box only? I installed this ddbr image on H96 Pro+ 3GB/32GB but doesn’t work well. When I’m on Android wifi doesn’t work, on ubuntu I can’t modprobe “wifi_dummy” or “dhd” module so not wifi, when I’m on LE doesn’t save any change that I do and LibreELEC setting doesn’t work also when I try to switch to Ubuntu or Android doesn’t go anywhere when it restart comes back to LE.

Is there anything that I can do or this image isn’t compatible with my box? if it isn’t compatible can you do a 3in1 for regular boxes? it wonderful to have all 3 systems in 1 box without changing sd card or usb.

Thank you for all your great job!


The system is android from the last image 2017.11.27 and when using the remote control it does not execute any command for example on the “Menu” key, the other keys pressed generate the wrong commands, for example the colored “blue” generates the digit 7


I’m surprised that this image was able to start on your TV box, it is assembled specifically for Khadas VIM2. I have no such model as you have, I don’t know why is not working.

The build of Android does @terry. This question relates to his competence. It is necessary to wait the answer from him.


I can be your lab rat if you want to. In fact to go back to stock firmware I had to erase bootloader in other to flash stock fw.

It almost worked except for the issues that I mentioned above


Does anybody had success in starting one of the related operating systems of this thread via wake on lan (wol)? I tried with multiple different machines connected via wired connection to the lan where vim2 resides without success. I know that the system is loaded through u-boot, but have no experience with it. I guess I need to enable it in u-boot.


I have not tested this mode. Try this documentation.


@balbes150 thanks for your response :slight_smile:

I partially succeeded to enable WOL for VIM2 through serial communication with kermit-module as it was described in the links you referenced.

Nevertheless: Under libreelec the VIM2 will always reboot when told to shutdown if I enable WOL no matter if any machine on the network posts WOL messages. The symptom is as followed: Once you shutdown from libreelec the VIM2 will power down. The blue led is on for a short period of time (1 sec.) then libreelec is powering on.

Under ubuntu and android all is working as expected. VIM2 powers down as required and turns on only if requested (via one of the enabled KBI boot triggers, e.g. WOL).

If someone is able to give his opinion how to further inspect this issue or has already a solution for this it would be superior.


The VIM hasn’t support for WOL function and only VIM2 has support for WOL function.
About the VIM2 alway reboot when it’s turned off. You can refer to follow path. Thanks.


Thanks for replying so quickly. As I wrote about VIM in my previous post I meant VIM2. I already updated the post to circumvent confusions.

Does your answer means that the kernel must be re-build from scratch with the provided patch?


Yes, you need to re-build the kernel with above patch.
Have a try. Thanks!


I have been watching this thread for a while and finally have installed the 3in1 OS on my VIM2.

Many thanks balbes150

My main use is Linux, then LE/Kodi. First question: the /dev/linux partition is somewhat small and after installing LibreOffice I am already getting size warnings. How can I increase the size (in Linux/Mate) of the root partition?


df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            1.3G     0  1.3G   0% /dev
tmpfs           300M   18M  282M   6% /run
/dev/linux      3.9G  3.9G   52M  99% /
tmpfs           1.5G   49M  1.5G   4% /dev/shm
tmpfs           5.0M  8.0K  5.0M   1% /run/lock
tmpfs           1.5G     0  1.5G   0% /sys/fs/cgroup
tmpfs           1.5G   20K  1.5G   1% /tmp
/dev/data        50G  1.4G   49G   3% /home
tmpfs           300M   32K  300M   1% /run/user/1000


You can transfer part of the system on partition /dev/data. Create a directory on /dev/data (e.g. var) to copy the current contents of /var to /dev/data/var, and add the fstab line to mount at system startup /var in /dev/var. Similarly, you can move the location of the other directories (/usr /tmp etc) on partition /dev/data. But keep in mind that when cleaning in Android or recovery partition /dev/data will be completely erased (formatted). If your main Linux system, I recommend installing the factory firmware of Android on it to install Armbian (in this case, the whole system Armbian will be installed in a large partition /dev/data). To write LE to external media and run Libreelec external media in the mode of placing the data in eMMC.


Thanks for the suggestions.

I think I will move some big directory to /dev/data as you suggest. The Vim2 is my only pc, when I get Linux/Mate setup I have a 128G SD card mounted permanently for music, pictures and video so don’t want to run LE from a card.


Uploaded the update image 3_in_1 20180115.
Also downloaded the tar file with an update for LE 20180106 legacy 3_in_1.

Pay attention, for those who have already established a system 3_in_1 download version 20180115 NOT necessary. You can upgrade your existing system 3_in_1 using a tar archive LE and 20180106 to upgrade Ubuntu to perform the standard procedure of update (apt update && apt upgrade).


I tried this and eventually worked out you can not mount /dev/data/var as it is not a block device: you can only mount /dev/data! So I spent the weekend and failed to setup a system with the 3in1 multiOS which is a shame. I did also try to do a symbolic link instead but could not get that to work either.


I had problems with this image trying to connect to a WiFi AP. Sorry I was trying so many things I do not have the specific error but it should be reproducable by just trying to connect to wifi from a fresh image install.


Was unable to use this image as it has no rndis support (which is in the Khadas 201709 server image). I do not have any ethernet network - only wifi and USB tether from phone.


Use the example in the form of a transfer directory /home on partition /dev/data. Also, there are keys “bind\rbind\move” for the command “mount”.

I don’t use WiFi (this is a bad decision for the network), so I don’t check work WiFi.