MultiOS_3in1 (Android+Libreelec+Linux) install to eMMC


#82

sudo apt-get update
sudo apt-get install libhybris

? and that’s it ?


#83

The build of Android does @terry, I only use it a finished version in their system. Therefore, it is necessary to wait the answer to these questions from him.


#84

Libhibris no repo in Linux, it is necessary to compile and configure yourself.


#85

Hi Balbes

Please could you write up instructions for how to.
I see many SBCs and TV boxes. They also use the T820 Mali with S912 - and are fast.
I just don’t know how to set up the GPU drivers.

Please help with this… makes a much faster Linux :slight_smile:


#86

Hi guys. Can anyone give here a sumnary of the steps needed to install this multi os version into the khadas vim2? After reading then whole thread i havent clear the steps at all.

Thank you. Regards


#87

The website added 2 new image firmware.

VIM2_AltLinux_Mate_4.9.40

VIM2_Volumio_3.14

Please note that this version , which is designed for installation to eMMC via a special system image that runs from external media.


Volumio for Khadas
#88

Added a new image 20171223 Ubuntu_Mate_17.04_4.9.40 to install to eMMC.
This option uses the entire eMMC for the root system.


#89

tks, is this one able to install using the usb burning tool exe?


#90

No. To install you need to use the instruction of the first message of this topic.


#91

Update LibreElec 20171221 system MultiOS_3in1. The update installation is performed as usual, copy the tar file in the Update directory and restart LE.


#92

thank you very much for providing and maintaining 3in1 upgrades 1in3 :slight_smile:


#93

I Could not found the correct link!


#94

Go to OP and find Yandex ddbr folder,
in there find VIM2_MultiOS_3in1 and LE_20171221
I only tried it on 3in1


#95

Meanwhile for 3in1 I replaced ubuntu by gentoo using (natively built) 4.9.40 khadas kernel.
It’s straightforward: just mount /dev/linux (e.g. from Android or LE) and put the gentoo stage3 content in place. Right now I natively build Mate and LxQt DEs. Keep you informed on WIP.

kvim2-extra ~ # uname -a
Linux kvim2-extra 4.9.40-khadas #1 SMP PREEMPT Sat Nov 18 23:17:57 CET 2017 aarch64 GNU/Linux
kvim2-extra ~ # cat /proc/version 
Linux version 4.9.40-khadas (root@kvim2-gentoo) (gcc version 4.9.4 (Gentoo 4.9.4-r1 p1.1, pie-0.6.4) ) #1 SMP PREEMPT Sat Nov 18 23:17:57 CET 2017
kvim2-extra ~ # eselect profile list
Available profile symlink targets:
  [1]   default/linux/arm64/13.0
  [2]   default/linux/arm64/13.0/desktop
  [3]   default/linux/arm64/13.0/desktop/systemd
  [4]   default/linux/arm64/13.0/developer
  [5]   default/linux/arm64/13.0/systemd
  [6]   default/linux/arm64/17.0 *
  [7]   default/linux/arm64/17.0/desktop
  [8]   default/linux/arm64/17.0/desktop/systemd
  [9]   default/linux/arm64/17.0/developer
  [10]  default/linux/arm64/17.0/systemd
  [11]  default/linux/musl/arm64
  [12]  hardened/linux/musl/arm64

it may be 4.9.40 khadas kernel does not stand the build stress, in which case I might need to boot a vanilla 4.14.x just for the purpose of building the DEs. Of course, for any DE to work with USB mouse and USB keyboard I will then need to reboot 4.9.40 khadas.
Let’s hope 4.15 brings more support.
update 4.9.40 khadas does not stand the native build stress, I’ll go for 4.14.x which I know to go strong.


#96

Please is a problem with the DVB remote control, the keys are wrongly assigned.
I compared remote.conf from another image that works but they are the same (I wanted to replace the file).
What is the problem and what files to compare?
Please, how can I fix it?


#97

Just want to say that I had a great time flashing MultiOS_3in1 to my VIM2 and I am happy to enjoy all the features provided by this build. It leverages the barrier of getting introduced in the various operating systems tremendously. :rocket: :ok_hand:

A side note for anyone that will get into the same situation:
When side loading a bootable linux image from sd-card or usb as described at the top of the thread in order to override the emmc you might not see any output on display wondering if it is working. Only the booting text “Khadas” was shown then the display went black (waiting longer than 20 minutes does not solved the situation). The emmc was populated with the stock android 7.1 that is currently shipped with VIM2.

I think my problem was the AVR in between VIM->AVR->TV. I spent a couple of long hours :slight_smile: until I plugged the VIM2 directly to one of the HDMI ports of the display and could see the booting messages of the linux.


#98

If I boot to linux (from emmc to ubuntu mate), I cannot access a disk formatted with XFS system. I have installed the latest XFS utilities via apt-get.

xfsprogs is 4.3.0+nmu1…
modprobe xfs -> results in “FATAL: Module xfs not found in directory /lib/modules/4.9.40”

Does anybody has an idea how to fix this?


#99

Write details about a specific system (Android Linux LE) in question. Describe the steps you did.

How long are you waiting for ? What is the dtb file.img did you use ? What firmware was in the eMMC before installing 3_in_1 ?


#100

Try how does XFC in Armbian. If everything works, you can replace the kernel in eMMC , at the core of Armbian.
Try to replace the current kernel an Ubuntu kernel from Armbian (it can simply be copied to eMMC from running from external media Armbian).


#102

Try to replace the current kernel an Ubuntu kernel from Armbian (it can simply be copied to eMMC from running from external media Armbian) - replacing ther kernel worked.