Manjaro Linux - Desktop Environment for VIM1 & VIM3

this image suitable for VIM2 ?

Yes just change dtb filename in uEnv.ini.

It should work. But I have only tested it on Vim1 and Vim3

I can’t seem to find manjaro download links within this topic, can you help?

What about multimedia and hw acceleration, what works?

Ignore my post, i’ve found the links.

Hi @Spikerguy
I just tried Manjaro-ARM-xfce-vim3-19.08.img on my VIM3. It works but has wrong colors. All green.
I know about a fix for this for Balbes his images, but that fix doesn’t apply to your images.
Do you’ve a fix for this? Or is there a better image I can try? Thanks.

We tried but it didnt work for us.
There are 2 options,
Option1:
Revert to older version of Android Emmc Image.

Option2:
Revert to
linux-vim3 kernel instead of linux-aarch64

I will be looking into this soon.

2 Likes

Thank you.
That I’ll do then. I had installed the latest Android version to see how it is. But I hate Android so much. Don’t care which version is on it…

Yeah, as a third option, you can erase eMMC if you want. At least that worked for me on the VIM3 to load latest Khadas Linux from SD card. Got rid of the tinted screen and USB problems.

Can it boot from SD card/USB without having anything in the eMMC? I though we need uboot in eMMC.

Sure, as long as there is a working u-boot on either eMMC or the SD card, the board will boot. If the image boots fine from SD card you can simply write the same image to the eMMC - the SoC in GXL and newer devices looks for boot firmware at the same offset on disk regardless of the boot medium (in older GXBB this is not the case, which is why the silly partitioning in the BSP u-boot exists).

1 Like

Thanks.
Is there anyone working on Mainline uboot for amlogic devices? also where can I find the BSP Uboot source so we can package it with the img itself instead of depending on the emmc android uboot?

https://github.com/u-boot/u-boot <= mainline u-boot source. The current 2020.01 release supports VIM1/2/3 and commits to support VIM3L are in the master branch ready for 2020.04 release.

https://github.com/LibreELEC/amlogic-boot-fip <= all the fip sources for easy distro packaging if you want to build u-boot like LE does. You’ll find the fip recipe(s) in my branch of the LE repo too.

mainline u-boot is not as fully featured as the BSP one (as usual) but there’s not a lot missing and it’s more than enough support for Manjaro and other distros to use things. Neil generally syncs the device trees and adds larger features once they’ve been through a couple of kernel cycles and are considered stable. He’s also one of the designated maintainers for Amlogic now, so getting things merged is fairly simple compared to a year or so ago. Contributions are encouraged!

4 Likes

Thanks alot for this information. Will try to see if I can get it to work with my Vim devices. At manjaro we try to get open source uboot to avoid firmwares so might give both branches a try.

I met someone from the lima team at fosdem and he was able to make lima work perfectly fine on amlogic devices. but i guess its just for the wayland and not xorg, So want to check is there any work going on for the vpu side for aml device?

Hello. please tell me how to fix emmc

What do you mean?

Do you want to install Manjaro Img to eMMC?

I want to boot fully from sd to solve the green screen problem

If you do not need whatever is on the eMMC now, you can erase the eMMC. All contents of the eMMC will be lost, so backup anything you want to save.
How to erase the eMMC on VIM3.

1 Like

Thank you very much.

By the way, there is still a great way to clean emmc, it is not listed there, this is through krescue, I highly recommend it !!!

2 Likes

Yes, Also a big fan of Krescue. It’s getting better all the time too. Every VIM* owner should get to know Krescue.

2 Likes