Mainline linux EMMC VIM3L

Hello @hyphop, are there any news about new ubuntu image for krescue VIM3L with mainline kernel?

Thanks a lot @odibox, it did the trick!!

ok will be soon :wink:


I have tried once again to get Khadas Vim3L to boot with Mainline Linux kernel and yet another failed attempt.

Linux kernel 5.9.11 and emmc was completely erased to make use of Mainline uboot.

This is the boot log
It is always stuck on Starting Kernel.... <= known working u-boot 2021.01-rc3 with some backports from u-boot-amlogic-next. See if that makes a difference.

1 Like

Thanks Chewitt.
I will give this a try. Your always here to help.

Much appreciated.

Here is the boot Log
Used this to flash the uboot

sudo dd if=/home/spikerguy/Downloads/u-boot.bin.khadas-vim3l of=${SDCARD} conv=fsync,notrunc bs=442 count=1
sudo dd if=/home/spikerguy/Downloads/u-boot.bin.khadas-vim3l of=${SDCARD} conv=fsync,notrunc bs=512 skip=1 seek=1

I tried LibreEelec 9.80.7 image and that worked fine so maybe I am missing something in my linux config.
I will look into it. I have checked the config and I have almost similar config like khadas used in fenix build.
Is there any patch needed to make vim3l work ?

UPDATE2: I can see both partition on sd card in uboot cli, so it is the linux side where it is getting stuck.

Does this command emmc-install practically complete the same thing like the dd command you suggested on the post’s reply Linux kernel 4.9.40 : 30 seconds delay when eMMC booting ?