Mainline linux EMMC VIM3L

for fun, try the previous version of the USB Burning Tool

@vkozloff It is the wrong image ! you were flashing it with VIM3 image, not VIM3L image, that should solve the problem

1 Like

try to put it here “Erase all”

1 Like

Yea, that one too :smiley: !

yes, everything is as expected, firmware incompatibility

1 Like

Here is your image!

1 Like

Sorry, my bad. Just downloaded VIM3L_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20191231.7z and flashing via USBBurnTool is in progress now. Will try to repeat the procedure with sd after that. Thanks!

yes, there you can choose “focal” or “bionic”, to your taste

1 Like

Yes, sweet or spicy :wink:

1 Like

Ok, I flashed it via USBBurnTool successfully, VIM3L boots, but when I just did

`sudo apt install linux-u-boot-vim3l-mainline linux-image-amlogic-mainline`

I finished with “No partition table - mmc 2” error.

maybe just burn mainline image instead :sweat_smile:

I wish it existed… :smiley:

only 4.9 for EMMC/VIM3L are there :slight_smile:

oh that’s nothing just boot mainline image from SD card then do emmc install

Just did that, using VIM3L_Ubuntu-server-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-20200530.7z (which has a new U-Boot). Ended up with the same “No partition table - mmc 2”… Looks like new U-BOOT can’t load Ubuntu from EMMC.

maybe there is still a mistake somewhere, check again

Please erase eMMC and try it again,
just click all the three side buttons to erase eMMC
refer here.

i will check your problem soon!

at this moment just try start krescue - krescue make emmc export as usb drive to host machine
and u can write this image directly to emmc

in any case we will prepare soon new ubuntu image for krescue and every body can write it without problem

1 Like

Thanks @hyphop, I already have tried this. I can flash any image with kernel 4.9 and old u-boot and it works fine, even via type-c, kresque image or kresque usb drive. When I erase emmc and write a 5.7-based image with a new u-boot, I have tried all available ways of erasing emmc and flashed the new image both via emmc-install and via kresque usb export. All tries ended up with booting into new u-boot with “no partition table found” message.

I had the same problem to write the image to emmc.
But now it works. (I have VIM3, not VIM3L).
Before i began, there was android on the emmc with uboot2015.

I have done the following steps:
1: Burn SD Card with SD_USB Image.

2: Boot from it, login, and run emmc-install command. Select the first option.
It lasts maybe 5min

3: After all files are copied. fdisk -l should look like this
Disk /dev/mmcblk2: 29.1 GiB, 31268536320 bytes, 61071360 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x11fcbcba

Device Boot Start End Sectors Size Id Type
/dev/mmcblk2p1 * 8192 524287 516096 252M c W95 FAT32 (LBA)
/dev/mmcblk2p2 524288 60460639 59936352 28.6G 83 Linux

  1. And here comes the problem. There are corrupted files on /dev/mmcblk2p1.
    So I have to mount it and copy all files from /boot to /mnt.
    You can compare the size of zImage or vmlinuz files.
    mount /dev/mmcblk2p1 /mnt
    cp -rf /boot/* /mnt

  2. Now you could do a reboot, disconnect power cable and after you power it again, it should work.

P.S. In my special case, I had a problem, that the new u-boot sometimes failed to read the data from emmc. Sometimes it has worked and sometimes not. (unable to select a mode)

fusb302_init: Device ID: 0x91
Warning: ethernet@ff3f0000 (eth0) using random MAC address - 52:1e:82:bc:58:b9
eth0: ethernet@ff3f0000
Card did not respond to voltage select!
Card did not respond to voltage select!
750056 bytes read in 241 ms (3 MiB/s)
starting USB…
Bus usb@ff500000: Register 3000140 NbrPorts 3
Starting the controller
scanning bus usb@ff500000 for devices… 2 USB Device(s) found
scanning usb for storage devices… 0 Storage Device(s) found
Setting bus to 0
Hit any key to stop autoboot: 0
SF: Detected w25q128fw with page size 256 Bytes, erase size 4 KiB, total 16 MiB
device 0 offset 0x160000, size 0x8000
SF: 32768 bytes @ 0x160000 Read: OK
** Script wrong header **

Device 0: unknown device
Card did not respond to voltage select!
Card did not respond to voltage select!
unable to select a mode
Speed: 1000, full duplex
BOOTP broadcast 1

So I have downloaded
and the Burner

Start the USB Burn Tool and import image
(VIM3.uboot-mainline.emmc.aml.img or VIM3L.uboot-mainline.emmc.aml.img)

Mark only Erase bootloader on the right side and press start.

After that, connect the Board through USB-C with the PC.
And press 3 Times in the first 2 seconds the function button in the middle.
The bootloader should upgrade now. It lasts maybe 30s. Then press stop.

Now disconnect all power cables for a few seconds and reboot.
Now every boot is successful.

I hope it helps someone.

Greetings Andreas