Linux Black screen after reboot tried to install TeamViewer

Hi All

I think I’ve destroyed my video driver after trying to install TeamViewer on my Linux image on my VIM3.
After the boot process I have a black screen.
I can press ctrl+Alt+F1 to get cmd line.

I just can’t figure out how to repair it.
I’ve tried:

khadas@Khadas:~$ sudo apt update
khadas@Khadas:~$ sudo apt full-upgrade

But no luck
Any suggestions?

Hi All
Still struggling with this one.
Can anyone one help me reinstall the display driver?
I think i’m going to need to uninstall the existing one and do a reinstall

Hello @Memorist

Can you provide the instructions you tried to install TeamViewer?
And please also provide which image you used。

I’m not 100% sure what guide i followed to try install.
I’d have to check the browser history on my Vim3, which i can’t open up.
But i think this was one of the links i tired.

After which i discovered there isn’t a working version of TV for the Vim3 chipset.

Image: Fenix 0.7 ubuntu 18.04.1 LTS

I found this link which worked for me.