Ubuntu installing software

I have basic experience with Linux systems, and am using your EMMC Ubuntu 18.04 Desktop version.

There is no Software Center app, and this is the standard app is used to install new software…
you do have Synaptic software installer, but the search function takes 10-20 min to work…

I have tried to install Teamviewer and Anydesk to allow easy remote access to the VIM3.
They have installed via sudo apt , but I am unable to open the applications.

What are other people’s thoughts?

@Binder Which version teamviewer you used ? Mayebe I can test it .

@Binder I just find a ARMv7 version in Teamviewer official website. I think It maybe can’t work in our board.It’s ARMv8 paltform . But I will try it tomorrow.

I found a teamviewer version on Synaptic, and downloaded it.
however it does not work

I have downloaded an ARM version of teamviewer, and tried to install it using Sudo apt -i (path to file)
It can install, but I cant use teamviewer.

Having remote controle of the VIM 3 would be Great.

Usually, this is done with:
VNC (fastest)
Anydesk (fast)
Teamviewer (medium)

Thanks !

@Binder Can you give me a link to download the teamviewer ? And I think you should use sudo dpkg -i xxx ,not sudo apt -i xxxx


the download link is:

There is a link for the armv7_32bit.deb package for teamviewer

cheers !

Maybe you can’t use it on VIM3. The teamviewer architecture is X86 or armhf. But our Ubuntu system is aarch64, so you may not install it successfully.

@Binder I try to install just now . You can install it but you can’t use it . When you run it in terminal.

$ teamviewer


Error: CheckCPU: unknown architecture 'aarch64'

It can’t be use in ARMv8 paltfrom.


So you can run the program NoMachine to allow remote control of the khadas Vim3

I download and install the armV8 version
however, i still cant connect…

well, just going to use ssh

@Binder I will try to install it later.

Sorry to jump in the conversation, but does this mean I can not install new software on Vim3 running ubuntu? I’ve been trying to install ExpressVPN with no luck. Attempts at a linux install bring an error that it isnt ARM, and ARM install wont work either. Please help if you can!

@OneLineOfCode You need to move in to a new topic

@Binder Can you give me another link to download it ? I can’t download it . It’s always half downloaded

why not use common openvpn ?
apt-get install openvpn

1 Like

Thank you, I will try that.

Anyone have any luck with Teamviewer?

I still can’t get it to install or work.
I’d prefer to stay with TV because i have a subscription for work purposes.
I’m using a VIM3 with Ubuntu.

The Ububtu images we provided are all arm64 architecture, but the Teamviewer for arm only have armhf architecture for RPi, the software is not compatible.