LibreElec whit bad colors

Sorry for revive this thread but i have a problem

I’ve just received the device and got the same problem, which lead me here and i erased the rom

Afterward my device stopped working, i don’t get boot screen and I tried to run different firmwares and nothing helped

What can I do?

Slow down, explain what happened in detail, maybe i can help you.

Don’t get nervous, i think there won’t be a problem returning to any rom image.

1 Like

Hi, Mosh1986:
Does your issues resolved?

And as what Tommy21 said, you need describe more details so we can help to locate your issue.


Same problem here, green screen, and no wifi connection… I hope next firmware will fix this.

Tried to boot it from sd, green screen and no wifi, gave up immediately.

So it isn’t possible to dual boot android+libreelec without issues?

we are doing that, will release in this week.

It is saturday, will u release libreelec for vim pro this week, or just next week?

Are testing now, will release tomorrow.

Thanks. :slight_smile: I can not wait. :slight_smile:

Hi, i just received my box and having the colours issue on Android roms, the original, Nougat, dual boot, Ubuntu en dual boot not starting… Hangs on loading.

Thanks in advance

Hi, Facadas:
Can you tell us more details for the issues? Basically, follows would be helpful for us:

  • A photo of the HDMI screen
  • The model of your screen
  • the ROM version you installed
  • others


Im not at home but soon as i am i will send the info you need. Meanwhile i CAN advance the follow info:
47’'Philips LCD,
Hdmi connetion randomly makes the image Pink or green
Tried all the Android roms from Khadas site and all had the some randomly issue. Wasnt able to start Ubuntu through dual boot and Wasnt capable of understand how to install Open libreelec.
Thanks for the quick reply.

It seems that it’s HDMI compatible issues, but I still need more details like a photo to ensure that. And do you have another HDMI monitor or screen? If so, kindly do a test on a new HDMI monitor.

For other questions, would better comment/post on the right topic, I will reply you there. we have to keep the topic readable.


1 Like

My monitor had this sympton once, turned out it was cable failure. Perhaps, you can try another cable to see if it was the case.

1 Like

Hi all,

toady I received two vims. All two were ok, booted to android. Then I tried to boot to LibreELEC:

  1. I prepared SD card and wrote libreelec firmware Vim_LibreELEC_V170116 from
  2. Device boot into green screen with strange error message, I don’t remember it and don’t have photo
  3. Then I wrote older libreelec image Vim_LibreELEC_V161003
  4. Device boot into libreelec but with bad colors
  5. So I folowed this thread and tried erasing rom by method #1
  6. After pressing Power + Function and short press Reset device switch off hdmi signal.

From this moment device doesn’t work, red led is on, screen is off (no signal to hdmi). Tried to press Reset, power it off and then after few secods on. Nothing helped.

Please help,

It was that :wink:
Changed cable and hdmi port and colours issue disapeared!!

Thanks to you all


Have you tried flashing firmware, as here?

Yes, I tried, no succes. Both LibreELEC imgs Vim_LibreELEC_V170116 and Vim_LibreELEC_V161003 are corrupt, see screenshot.

I also tried another firmwares and I’ve got success with Vim_Ubuntu-server-16.04_V170515 and Vim_Marshmallow_Root_170121.

Hi, our official LibreELEC built doesn’t support eMMC/USB-C installation yet, you can try one of the two follows to install LE ROM on VIM:

And you can also try the developer Balbes150’s build, he develop many good ROM on VIM, check below for more details: