LibreELEC for Khadas EDGE (RK3399)


This image on EDGE+Capitan should work without changes. Download. Unpack. Write a special program on the SD card. Connect SD to the EDGE (Capitan). Turn on power. The system should start. Do you have a UART console ?

Try the 20190517 arm version.

LE is no patch to work NVMe. I’ll add it to the next issue. The patch is in Armbian with kernel 4.4

1 Like

Hi @balbes150. The borad work well,just I can’t find my M.2 SSD.My command is df -h ,I don’t find it. and in /dev I don’t find the node.And I will test with 20190517 arm version.

@balbes150 Thank you so much, I’m really excited! I’m using the “rk3399-khadas-edge.dtb” DTB file. I didn’t see any specifically for the Edge-V. (In fact, I can’t even find any others on your build - is there a site to grab the dtb files from?)

I’m familiar with for Amlogic, but don’t know of a Rockchip equivalent. I found references on the lkml for a “rk3399-khadas-edge-v.dtb”, but have no idea where to find this file. I checked in the nightly Armbian Ubuntu “next” image you provided, but didn’t find it in /usr/lib/linux-image-next-rk3399-tv/rockchip/, only the -edge version.

Khadas Edge V5 seems to have extra gigabit LAN and PCIE, not present in Khadas Edge. So it’s dts for LibreELEC can perhaps just get changes from mainline patch @numbqq posted.
Also ‘vopl’ must be disabled for 4K playback to work correctly.

I hope the mainline driver for the wifi for Khadas Edge V5 will also be able to be build in future.

1 Like

There is no Khadas Edge V5. It’s Edge-V.

Khadas Edge is an expandable Rockchip RK3399 board with goldfinger.
Khadas Captain is the carrier board for Khadas Edge.
Khadas Edge-V is a Khadas VIM form factor Rockchip RK3399 board.

You can find the comparisons here:

1 Like

Get rid of very outdated systems. :slight_smile:
All modern systems have not copied anything for a long time to run. On the RK3399 platform, to choose which DTB will be used, you need to edit the file “/extlinux/extlinux.conf”. Change the name in this file to be used. You can see the list of available files in the /dtb directory on the recorded media. This principle is common for LE and Armbian.

Oh, I see. So I don’t actually need the .dtb file, I just need to reference it in the extlinux.conf? Very cool, I will try that. How difficult is it to build LibreELEC with the mainline patch @mo123 referred to?

Hmm, I set the extlinux.conf file to FDT /dtb/rk3399-khadas-edge-v.dtb in your LibreELEC-RK3399.arm-9.1-devel-20190607091142-a41fdf1-khadas-edge.img image, but unfortunately it won’t boot now.

Ok, I made some progress! I stole rk3399-khadas-edgev-linux.dtb from Armbian_5.88_Rk3399-tv_Ubuntu_bionic_default_4.4.154_20190612.img and placed it in dtb/ directory, edited extlinux.conf to match, and now the network is stable and it sees /dev/nvme0, which is all great! I just need to figure out how to make LibreELEC mount it at boot and I should be good to go. Thanks again for all your effort @balbes150!

Edit: Seems I spoke a little too soon. Seems inconsistent whether the network is bad or not, but I did at least get the NVMe to show up and auto-mount. (For future Googlers, just needed to copy /usr/lib/udev/rules.d/95-udevil-mount.rules to /storage/.config/udev.rules.d/ and add “nvme*” to the harddisk lines 6 and 13.)

Also, it runs very hot. I wonder if it’s overheating and that’s what is causing the bad network performance?

Do you have a radiator and a fan, plastic case ?

Just the heatsink at the moment. The heat doesn’t seem to be the issue, since the Armbian image also runs hot to the touch, but has no network problems (consistently got >75 MB/s transferring via NFS to the m.2 SSD). Not sure what’s going on with the LE image and it’s hard to get any logs off the device because, for example, if I run dmesg, it causes SSH to hang.

To work correctly, you need not only DTB, but the kernel itself to change to LE. I plan to do this for the next version. I’m busy with other urgent work now.

1 Like

Oh I see. I’ll await your excellent work then. My project doesn’t require networking after initial setup, so now that I’ve got the m.2 working I’m in pretty good shape.

Edit: I’m not sure what the difference is, but on your images I have the network problems in both Armbian (Armbian_5.88_Rk3399-tv_Ubuntu_bionic_default_4.4.154_20190612.img) and LE (LibreELEC-RK3399.arm-9.1-devel-20190607091142-a41fdf1-khadas-edge.img). However, using Ubuntu from the downloads page (Edge_Ubuntu-server-bionic_Linux-4.4_arm64_SD-USB_V20181115.img), I have no issues. I’m going to try stealing the DTB from that image instead of Armbian to see if it makes any difference.

Edit2: No difference…

1 Like

I am testing the network on EDGE+Capitan+Gigabit network, no problems found. It is possible to EDGE-V other configuration is needed (another DTB). Which hub do you use ?

I’m not sure what you mean by ‘hub’ - but I have the Edge-V SBC.

A hub is a device where all the cables of a wired network are connected. In a home network, this role can be performed by a router with a built-in hub for several ports of a wired network.

Oh, sure. I have various switches. I’ve tried a NetGear Gigabit switch, an Ubiquiti EdgeSwitch, a Cisco Small Business managed switch, and an Ubiquiti in-wall AP. Also, they all work just fine with the Edge-V when I run the Edge_Ubuntu-server-bionic_Linux-4.4_arm64_SD-USB_V20181115.img image, so it seems to be something specific to the Armbian / LE images on the Edge-V that are the problem.

@balbes150 is there anything I can do to help test the Edge-V with your images?