Lastest mainline Ubuntu on SD/USB not bootable

Current system on vim3 emmc is VIM3_Ubuntu-server-focal_Linux-4.9_arm64_EMMC_V1.0.7-210625.img.xz. I used Etcher on windows 10 to flash VIM3_Ubuntu-server-focal_Linux-5.12_arm64_SD-USB_V1.0.7-210625.img.xz to an micro sd card without any error. However, when I tried to boot from SD/USB, screen showed a khadas log and vim3 would shutdown in a few seconds. I googled the problem and I guesse it’s related to uboot. But i know nothing about uboot, can someone point out the right way to get mainline ubuntu boot?

just start Krescue from sd and install anything what u like by one click :wink:

I tried Krescue but the download speed was very slow since I’m in China. I even tried upload the downloaded img.xz with winscp to krescue. After installing the mainline img.xz to emmc, I still failed to boot up

  1. u need write mainine uboot to emmc or spi - Index of /Firmware/uboot/mainline/ u can do it via krescue (Mainline u-boot for khadas sbc) or use other soft
  2. try boot up mainline linux from sd/USB

PS: just check Krescue tread for other info

HOW-TO easy write mainline uboot to EMMC or SPI

Krescue - main menu → advanced - > experimental

  • Update/Write U-Boot by online to EMMC
  • Update/Write U-Boot by online to SPI-Flash

I don’t know how to manually flash uboot to emmc so I used Krescue’s experimental feature. When I checked the uboot version of emmc in Krescue, it showed the current version is 2021/07 which is not identical to firmware website. I thought the uboot should be new enough to boot the mainline Ubuntu from SD/USB but it still failed. Once vim3 powered on, boot logs showed up with the Khadas logo. After a few seconds, vim3 automatically powered off.

  1. maybe something wrong with your sd card ? or was writen not properly images?
  2. try this one

Krescue - main menu → advanced - > experimental

PSS: provide boot fail logs from UART its will be more usefully :wink:

I actually tried both the sd card and the usb, which works on my other SBCs. Thank you for the help, I will try this image later.

I don’t know how to get fail logs from UART so I directly took a picture. This situtation happened after I upgrade the Uboot in Krescue. If I try to boot from sd card directly without upgrading the uboot, nothing will show up after the khadas log.

@hyphop could you give me some hint about the problem?

we will check Ubuntu images later ! may be have some regression , plz wait

PS: at this moment i can confirm next image bootable

Thank you for the reply. I also would like to know if it’s possible to set a static IP with custom gateway and dns in Krescue since I set up a proxy server in my local area network.

@hyphop Is it possible to setup a http proxy in Krescue?

not yet ! at this moment eth/wifi works in dhcp mode