Khadas Vim3 + CoreElec all work!

And if i cannot use it as a tv box should i send it to you? :thinking: Sorry, you are Russian (sorry for the comparison)?

Sorry I couldn’t catch that. I:m not into xenophobic comments.

1 Like

Where did I ever say that or insinuate that? I’ve tried to help you but I’m getting bored of this now buzz, instructions for Linux can be found elsewhere.

Hello, Sorry I have not been following this issue, as I do not have the VIM3L. I am curious if you were unable to flash firmware to the VIM3L using MASKROM mode?

You warned about the possibility of errors in the firmware of the architecture, and I sincerely thanked you for it :+1:. But then you wrote that I was 100% wrong when I claimed that there was no working image for Vim3L. Gave me the link :). Where do you think I looked for ready-made images? :). Now show where among the images you have listed, is there an image for installing (or reinstalling) CoreElec on Vim3l? Why do I need an openwrt or ubuntu on a TV box (of course I can install it, but why?!? I try use Vim3L how TV box, if I dont use this device how TV box, when I only try use how network storage with openwrt or ubuntu) :). I could not install the working image of the android system. I took it from the site (there is one more image here, I also tried to clone it SC_VIM3L_ATV_FINAL-v1.0-20191023), it did not help either.

ok! No problem :)… thanks for trying :slight_smile:

Hello Friend! I dont understand what mean “MASKROM mode”, I tried TST mode (recommended): 3 clicks for 2 seconds (as per the manual) and the Power-LED (Blue) turns OFF. I also tried through successive presses of the shutdown and reboot buttons ( Keys Mode (U-Boot is Running Normally). They are not bootable android image :). This image android system is not ready for the basic installation (I clone image with Etcher and DD linux utility dd if=sdcard.img of=/dev/sdX bs=4M), most likely it is for updating :slight_smile: or maybe not normal work U-Boot for Vim3L device. The seller answered me that he would prepare a normal image for recording on CoreElec. Maybe in a couple of months it will be possible to reinstall :).

maybe I have a similar problem :slight_smile: and it’s not even about the images for recording :slight_smile:

If you have been messing with dd then its highly probable you have messed up your uboot and the only path back is mreg

I would say read a lot more before trying to flash anything. All these procedures are well documented here and at the CE forum.

Shoog

You probably don’t understand that the firmware didn’t happen :), you can’t ruin anything if you can’t even flash it :).

you write obvious and banal things :slight_smile: without understanding problem :), and I don’t understand why you are writing this to me. Please do not write me anymore please (in your messages there is no useful information for me :)).

You can enter TST mode to reflash the image in any situation.

1 Like

I use Etcher for clone CD:
`


this message when cloning an official android image. The image is not bootable.

After enter upgrade mode do you follow the documentation to flash your device?

These Khadas are too complicated for normal users.
Perhaps for learning in universities or other similar uses, but to use as a movie player for the general public is a mistake.
I regret not having bought the RBP 4.
Everything would have been easier.

1 Like

:+1: I’m sorry about that too.

There really is nothing complicated about flashing ROMs to these boards and they come with software preinstalled anyway.

If you can’t manage it on the vim then its unlikely you will fare better with the pi’s ( in every way an inferior product).

Shoog

3 Likes

I had an RB2, after RB3, and since it was very slow, I thought about buying a new, more powerful SBC. VIM3 goes very fast, the A311D processor is very good, but I don’t like the design of the VIM3 board, 3 buttons together. power-function-reset? press for 3 seconds? a fan that does not work with a simple CoreElec-LibreLec and makes a lot of noise, and costs 15 euros. An operating system that if you do not install the nightly version does not work completely …
and the way to install the operating system with the usb burning tool is to cry :wink:
---->ES CRITICA CONSTRUCTIVA!

2 Likes

The reason you have to use the AMLogic burn tool is because unlike the pi’s which make you use shitty slow SD cards (which have a horrible habit of dying prematurely) it has blisteringly fast onboard EMMC storage. Also it actually has a power button rather than just having to pull the plug (the main reason for SD card corruption in the pi’s). And to complain that a bunch of volunteer developers haven’t yet developed fan speed control for one board out of a dozen they are working on - is petty at best.

Me thinks you protest to much.

Shoog

I think it’s a matter of empathy …
In computer science it is usual to make programs without thinking about the end user, and not to question whether it is easy or difficult because they do know how to do it, others should also know it.
The simplest would be to copy a * img file to a usb pen and automatically install it in the internal memory. Everything else is eager to not make things easier for users. Cheers

2 Likes

Android deliberately makes it difficult because otherwise people would be trashing their devices all the time. The only OS that AMLogic supports is Android and this is why it is intrinsically and by design difficult to load new software. Its only because of mostly volunteer developers that there is any other OS support and they all have to work with the “difficult” Android u-boot and dtb system.

My point is a bit of gratitude to those volunteers is a more appropriate response than bitching about a few minor inconveniences.

Shoog

1 Like

There are no Android images available that use a method like Etcher, these images are designed to be installed by the USB Burning Tool or Linux burn tools. Sometimes(for Windows users) the Burn Card Maker can use the images to create a card that can be used to install the update.

If the firmware has been damaged somehow, erasing the eMMC(Will wipe all data and apps) or using MASKROM(Mregister/TST) should allow the USB Burning Tool to burn the image.

I have never encountered such a problem when recording any kind of images on Etcher. But it doesn’t matter since I used the Linux system DD utility for recording, and this is a 100% working version (no exceptions)! The problem is not in the recording methods, the problem is in the image for recording (it is damaged. The day before yesterday I could write and it just did not load, but yesterday I repeatedly downloaded the image again and could not write the image to disk again :frowning: the same etcher wrote that the image was damaged).

I made a backup of an already preinstalled system. The problem is not that something could be damaged :)… in any way, the recorded image is not recognized by Vim3L according to the instructions. By the way, the delay in the system also seems to be caused by the poor quality of the remote control, most likely because of this, slowness is added … in general, this device is one continuous problem, both in software and not in software. I don’t understand what the seller was counting on when he put it on sale (in the next topic, people also complain that can’t turn on Vim3L from the remote control).

1 Like