Khadas VIM2 as Bitcoin Cryptocurrency Mining Hardware


#1

Hello all, I was wondering if anyone has any instructions on how to do some mining with the vim2 max?

I have followed these tutorial:
https://www.novaspirit.com/2017/10/19/crypto-mining-sbc/ http://raspberrypi4u.blogspot.com/2017/11/raspberry-pi-bitcoin-miner-monero-xmr.html
https://github.com/OhGodAPet/cpuminer-multi

Neither of them work. While I am in the folder of each and run ls command the minerd is not listed.

I’m running Ubuntu mate if that has anything to do with it.

Thanks


#2

#3

what are you looking to mine? Anything in particular?

Ive put together a detailed guide for odroids here - https://goo.gl/xbWBqp most of which you can pull across. Not many miners seem to work for armv8 out of the box - ive paid someone to do the port as the armv8 boards have much better power efficiency and this is the reason ive bought the vim2 board - too see if its going to be the backbone of my next cluster! See here for the miner - https://github.com/fireworm71/veriumMiner . If you need help getting going / list of pools etc. then head over the the slack http://slack.vericoin.info (ping me on there same username as here)

Im currently working out the most i can get out of the board - but its looking promising!


#4

Thanks birty I will look at this soon. The guy from novatech spirt did a review on vim2 and had a miner going mining magi coin. Myself I’d like to mine Monero and already have pool setup with minergate.

Thanks again and I’ll get back with this later today.


#5

Have had a quick skim and he has only every used the rasp pi3 for his mining tests, and whilst its an armv8 chip it uses a 32bit os with the chip running in aarch32 mode so these miners all work. VIM 2 is a 64 bit OS and runs in aarch64 mode… To get them going you will need to start by replacing all the ifdef / ifndef (arm) with something to look for aarch64 as well and then fix all the other compile issues. I did that change and whilst it gets further is still isnt picking up the arm versions of the aes code for instance. I paid someone BTC to port the verium miner code to aarch64, not sure how many other work out of the box. Most of the miner code comes from one repository in github originally and there doesnt seem to have been much / any work done on porting to aarch64. Also worth running the numbers on profitability over the various coins - things like XMR are well established and have lots of hashing power on them making it hard to compete. Look for new(er) coins and get in early, more risky but higher potential rewards if they work! Will post back here when i get final numbers for the VIM2 mining - just trying to work out how to turn off CMA at the moment - its stealing my memory!

note that aarch64 is meant to read double underscore aarch64 double underscore and same for the arm but it appears double underscores makes words bold on this forum :slight_smile:


#6

Update:

This does work on Vim2 Max with Ubuntu Mate from balbes150 Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

It only works for mining Magi Coin and here are a list of pools https://poolinfo.systms.org/ currently I am using XMG Luckypool for test runs and to see how it goes…

I will be trying other alt coins soon. so stay tuned. If anyone else and tried any please let me know.

With mining Magi coin with the VIm2 Max I am very pleased with the outcome. Right now the Vim2 is outperforming my i7 quad-core mackbook 8 gig ram and ssd.

Many thanks and happy new year to all.


#7

Did you do everything that was written in the tutorial or did you skip some steps? I tried doing everything, but cannot manage to get the miner working? when I try to run minerd it says there is no such file.


#8

Which miner the wolf m7m?
If so open terminal and run this command

cd wolf-m7m-cpuminer

Then type

ls

This should return all files and folders in the directory. Look for minerd it should be highlighted blue (I believe). If it’s not there you need to compile it again and make sure there’s no errors. If it is there then post a screenshot of what it looks like when you the command ./minderd m7m … to start mining. I’ll help you get going.


#9

Hello,I tried putting together the veriumminer but no luck :confused: do you have the verium miner working on a khada VIM2? If you do could you write it up because i seemed to have followed every step correctly,yet it says ./cpuminer no suchfile or directory…


#10

I eventually got the magi coin miner working, thanks!


#11

Hi - if you use this miner https://github.com/fireworm71/veriumMiner it will work out of the box on a VIM2 if you follow the install instructions. You need to get a kernel with hugepages enabled to get the best out of it, which ive done - and am trying to turn CMA off to get even more out of it! Let me know if that doesnt work


#12

#13

Hi, forks:
We are very happy that your guys develop mining machine with VIM2, we don’t have too much experience on it at the moment, but obviously, we will focus more on this in the future :blush:

@faddat you might also interest in this.

Enjoy!


#14

hi Bbirty, I’ve been following your cluster builds for a while on Verium Slack channel wanted to say well done and thank you. I decided to try the VIM2 as well, I followed all the instructions for for the FireWorm Verium miner. installed eveything. ran the ./cpuminer it started or so I thought I got a connection to Slothpool 8 threads started. then Khadas Killed the Process. I am now stuck is there any chance you could do an instructional video or just a guide for noobs like me for the Khadas Vim2 (How To Mine) I have no idea how to get HugePages. any pointers would be appreciated.


#15

Hey @SuprMACD - glad all the info was useful! To get this one going you will just need to use less threads - it has 3gb of ram so 8 x 3way threads doesnt quite fit (3072mb) - in theory you could get 7 three way and at least 1 one way in but there is a large chunk of RAM reserved for CMA (Contiguous Memory Allocator) - trying to get that turned off in the kernel but not having much luck as disabling it in the kernel config breaks a lot of the amlogic drivers that seem to need it! Currently waiting on a usb to serial device so i can get at uboot and modify the boot options to turn cma off instead to see if that works! To enable hugepages you will need to recompile the kernel with hugepages options enabled - however in the mean time see here https://goo.gl/kAZ8kQ for a kernel that you can just copy over to your VIM2 that has it enabled already. Just copy the uImage file to /boot/uImage and reboot - rename the old uImage first so you can go back if needed :wink: You will defo need a heatsink as well.

Will get round to writing up some instructions when I have got the CMA bit sorted out.

Also planning something a bit special with VIM2 at the heart - just working on numbers at the moment!


#16

Thank you for taking the time to reply birty. Though I’m not a complete noob to crypto mining this khadas vim2 configuration is way beyond my skill set. Back in 2013 I mined so many different alt coins with my gpu rigs but when the bottom fell out of Bitcoin and Asic’s came into play I cashed out. Which I regret now. But I’m fully back in now. Starting off small. I got x 4 Vim2 and an odroid x4. I really like verium and that’s what I’m backing it and want to mine it. I’m hoping to get the vim2’s up and running it took ages for them to arrive and they are sitting here dormant not doing much. I tried to run one again the other day but still the same problem. Hugepages Not present on Ubuntu Duel Boot image. I’m wondering if I should just install the Ubuntu image as a stanalong, would that help? thanks for the info so far. All help is appreciated, it would be fantastic if you could put a guide together to help me and the community with this. I’m a bit disappointed with Khadas with not having their stuff together like the XU4. Are you on Steemit? I’d like to send some steampower your way. Regards Max


#17

Hi - I will put a short guide together - probably not as detailed / long as the xu4 one thou! Will post link here when done - will be on steemit with the last ones.

Have to be said I’ve found the khadas staff really responsive!


#18

I’ve never heard of Verium, what is it?


#19

faddat - its a CPU mineable crypto currency - more info here https://bitcointalk.org/index.php?topic=1540023.0

Slack and Discord groups are the best place for any help / assistance - I’m birty on both


#20

@birty What is the outcome of having only one Vim2 max running from your tests? I get about 1 XMG in 2 weeks of running. Hardly anything to write home about.

Now that Litecoin Cash LCC has arrived I ordered 2 Gridseed Orbs I’d like to run cgminer on else, I’ll have to get a raspberry pi 3. Which I might still do.

The whole idea behind all of this is to keep power consumption low, profits high.

BTW if anyone is interested my business partner and I have built an amazing website to monitor portfolios, get news, exchange, etc… We are adding a ton of features and plan to have them rolled out soon but the gist of the site is already completed. Please let me know what you think https://cryptoexchangefinder.com/

Thanks,

Eric